Windows 7 users: what sound card do you run?
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1

    Default Windows 7 users: what sound card do you run?

    It seems like a lot of the sound cards Ive researched have various issues with Windows 7 compatibility. So Im wondering what you guys are actually using and getting results with.

    Most of the sound card discussions I read talk mostly about USB/Firewire units. To be honest I would really like a PCIe board since Im using a tower (not laptop). But I see very few with the digital dj in mind.

  2. #2
    Tech Mentor Wuz's Avatar
    Join Date
    May 2008
    Location
    Brisbane, Australia
    Posts
    343

    Default

    are you using 64bit windows 7 or 32?

    maybe the issues with the AK1 were related to that...
    < Progressive | Trance | Full On Psy | Liquid DnB >
    < Xone:1D:22:2D + Vestax PadOne >

  3. #3
    Dr. Bento BentoSan's Avatar
    Join Date
    Mar 2008
    Location
    Perth, Australia
    Posts
    6,356

    Default

    Echo Audiofire 4 is working a treat, as is my presonus firebox - still having issues with my NI audio 4 but other users have it working on windows 7 fine

  4. #4

    Default

    Quote Originally Posted by Wuz View Post
    are you using 64bit windows 7 or 32?

    maybe the issues with the AK1 were related to that...
    64 bit. It seems like almost all of the NI line have issues with W7.

  5. #5

    Default

    Quote Originally Posted by Arkanjel View Post
    64 bit. It seems like almost all of the NI line have issues with W7.
    nope, didn't find any issues whatsoever with A8dj and W7 on multiple PCs...
    DJ Blofeld - The Evil Genius
    I shall look forward personally to exterminating you, Mr. Bond.” Ernst Stavro Blofeld to 007
    Doomsday device: TRAKTOR SCRATCH PRO, AUDIO 8, VCI-100black 1.3, 2x Technics SL1210mkII

  6. #6

    Default

    Quote Originally Posted by Kupujte_Pytle View Post
    nope, didn't find any issues whatsoever with A8dj and W7 on multiple PCs...
    All I can say is that nearly every card from NI, M-Audio and Presonus still have their W7 drivers in Beta testing. So it works for some people but way more are having problems. Go to their respective forums and title search "Windows 7" and look at the laundry list.

    It should be expected with a new os. But W7 seems especially quirky.

  7. #7
    Tech Mentor Villinus's Avatar
    Join Date
    Jan 2010
    Location
    Berkeley, Ca
    Posts
    297

    Default

    I'm using my original MBox, which is working fine, alhough it only gives me 2 mono outs, but I'm a beginner, so it works fine for main mix and headphone cue.

    No driver issues whatsoever. W7 64 bit, 2010 HP dv6.

  8. #8
    Tech Convert
    Join Date
    Dec 2008
    Location
    Australia
    Posts
    7

    Default

    I'm using a Novation Nio 2/4 and it works flawlessly on win7, very happy with

  9. #9
    Tech Convert
    Join Date
    Apr 2010
    Posts
    9

    Default

    Running Windows 7 64bit on my 2009 Lenovo y450 and using an Maudio Fastrack Pro. Works perfectly with its Win 7 drivers.

  10. #10

    Default

    Quote Originally Posted by rhymes116 View Post
    Running Windows 7 64bit on my 2009 Lenovo y450 and using an Maudio Fastrack Pro. Works perfectly with its Win 7 drivers.
    can you say it works better than on XP or Vista? as I used this device in the past on multiple machines and had bit of trouble with it every now and then (especialy full no-sound drop-outs) while on XP or Vista.
    DJ Blofeld - The Evil Genius
    I shall look forward personally to exterminating you, Mr. Bond.” Ernst Stavro Blofeld to 007
    Doomsday device: TRAKTOR SCRATCH PRO, AUDIO 8, VCI-100black 1.3, 2x Technics SL1210mkII

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •