Results 1 to 5 of 5
  1. #1
    Tech Mentor
    Join Date
    May 2008
    Location
    Bolgare (BG), Italy
    Posts
    113

    Default Filter/FX lights: possible solution for Windows (BETA)

    I've found a possible solution to manage in the right way FXs and Filters leds.
    It's based on the following programs:

    1) MIDI Yoke Junktion (http://www.midiox.com/index.htm?http....com/myoke.htm)
    2) MIDIOX (http://www.midiox.com/)
    3) Bome's MIDI Translator PRO (http://www.bome.com/midi/translator/)

    I've configured MIDIOX and MIDI Yoke as shown in FIG1 (MidiOX_cables.png) and FIG2 (MidiOX_MidiDevices.png).
    Traktor MIDI settings are shown in FIG3 (Traktor_Midi.png).

    Bome reads MIDI signals and through some global variables (Bome_Variables.zip) store the value of the following leds:
    - Filter A
    - Filter B
    - Filter C
    - Deck A FX button 1 & 2 (FX Bank A & B)
    - Deck B FX button 1 & 2 (FX Bank A & B)
    - Deck C FX button 1 & 2 (FX Bank A & B)
    - FX button 1,2,3 & 4 (FX Bank C)
    - Cue B, Cue C
    - Loop B, Loop C
    - Key B, Key C


    This is the final leds' behaviour:

    - FILTER/FX
    * Filter A ON => Deck A FX button 1 & 2 (FX Bank A & B) OFF
    * FX button 1 (FX Bank A) ON => Filter A OFF, Deck A FX button 2 (FX Bank A) OFF, Deck A FX button 1 & 2 (FX Bank B) OFF
    * FX button 2 (FX Bank A) ON => Filter A OFF, Deck A FX button 1 (FX Bank A) OFF, Deck A FX button 1 & 2 (FX Bank B) OFF
    * FX button 1 (FX Bank B) ON => Filter A OFF, Deck A FX button 2 (FX Bank B) OFF, Deck A FX button 1 & 2 (FX Bank A) OFF
    * FX button 2 (FX Bank B) ON => Filter A OFF, Deck A FX button 1 (FX Bank B) OFF, Deck A FX button 1 & 2 (FX Bank A) OFF
    * ... same for deck B and C ...

    - "NORMAL" mode VS DECK C mode: when you switch from Normal mode to Deck C mode (and viceversa), Bome's send multiple messages in order to match the correct configuration for the current enabled Deck.


    This solution is in beta testing and it seems to work...

    If you want to try, follow this steps:
    1) turn on VCI and wait until lights on
    2) start MIDIOX
    3) start Bome's MIDI Translator and load the attached configuration (VCISE.zip)
    4) start Traktor


    I know, it's not a simple solution, but I hope it works also for you...

    EDIT: Before start Traktor with this configuration, check that the key functions for deck A,B and C are ON, because when Bome's starts that variables are initialized to "light on"...
    Attached Images Attached Images
    Attached Files Attached Files
    Last edited by fcarsana; 10-24-2008 at 02:45 AM.

  2. #2
    DJTT Dominator JesC's Avatar
    Join Date
    May 2008
    Location
    127.0.0.1
    Posts
    5,483

    Default

    Nice ill check it out. btw fx lights dont bother me too much
    Controllerist: Think different | SoundCloud | MixCloud | Twitter |

  3. #3
    Mr. Golden EanGolden's Avatar
    Join Date
    Mar 2008
    Location
    San Francisco
    Posts
    956

    Default

    thanks for trying so hard to find a solution and sharing it. Good work! Remember though that this problem will be fixed in traktor pro

  4. #4
    Dr. Bento BentoSan's Avatar
    Join Date
    Mar 2008
    Location
    Perth, Australia
    Posts
    6,378

    Default

    The next version of Bomes midi pro will make sharing templates that require bomes midi programing a hell of alot easier. You should see the crazy system i had going on not that long ago to have proper control of the LEDs :\

    Good work

  5. #5
    Tech Mentor
    Join Date
    May 2008
    Location
    Bolgare (BG), Italy
    Posts
    113

    Default

    Quote Originally Posted by eangolde View Post
    thanks for trying so hard to find a solution and sharing it. Good work! Remember though that this problem will be fixed in traktor pro
    Thank You!
    I'm very happy that Traktor Pro will fix this problem, because this solution is a bit complicated... :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •