Top Left button LED only?
Page 1 of 5 12345 LastLast
Results 1 to 10 of 48
  1. #1
    Tech Student
    Join Date
    Jan 2010
    Posts
    3

    Default Top Left button LED only?

    i'm not sure how to safely reset this thing. from what i've read, having only the top left button lit means the Midifighter isn't being recognized as MIDI device? also, the usbaudio.sys file is nowhere to be found.

  2. #2
    Tech Student
    Join Date
    May 2009
    Posts
    3

    Default Same issue

    And it sucks help!!

  3. #3
    Tech Guru Fatlimey's Avatar
    Join Date
    Mar 2008
    Location
    Redmond, WA
    Posts
    1,158

    Default

    LED1 (top left) means "USB unconnected".
    LED2 means "USB enumerating".
    LED3 means "USB connected".

    LED1 on means that your USB host attempted to enumerate the device and failed. The computer asked the MidiFighter for it's USB Descriptors and failed to find a driver for them, so it shuts the MF down.

    Assuming you are on a Windows machine, you need to make sure there is a "USBAUDIO.sys" file in your %WINDOWS%/system32 folder. You should also check your Device Manager for unassigned USB devices (icons with a red "X" on them). Select and delete these devices, then re-attach the MF to your PC to try again.

  4. #4
    Tech Student
    Join Date
    May 2009
    Posts
    3

    Default

    What about on a mac?

  5. #5
    Tech Student
    Join Date
    Jan 2010
    Posts
    3

    Default

    Midifighter is no longer showing up on my computer, even as an unrecognized device. I've plugged it in to different systems and used a different cord, all to no avail.

  6. #6
    Tech Guru Fatlimey's Avatar
    Join Date
    Mar 2008
    Location
    Redmond, WA
    Posts
    1,158

    Default

    I really don't know what to say. The fact that the LED is lit (and I assume that the Midifighter goes through it's power-on lightshow before leaving LED#1 on) tells me that the Midifighter is functioning correctly. Any LEDs lit means that the firmware is running.

    Without a detailed dump of the USB chatter between the Host and the MF, or a screenshot of the MF device as it shows up in the Windows Device Manager, I can't really help any further.

    Describe what you mean by "It doesn't even show up"? Take me through the steps one by one, starting with a description of what plugs into what, how many other USB devices you have attached and to what, tell me what lights flicker, what appears in the Device Manager and the exact order you are trying to plug things in.

    Let's sort this one out, it sounds like there's something to learn here.

  7. #7
    Tech Wizard
    Join Date
    Jan 2010
    Location
    Shanghai
    Posts
    25

    Default

    I Am Having the exact same problem.
    only top left LED lights up.
    not nice flashing light boot up seq.
    just a brick right now.
    please advise on how to re flash or Reboot to got to factory default.
    cheers

  8. #8
    Tech Guru Fatlimey's Avatar
    Join Date
    Mar 2008
    Location
    Redmond, WA
    Posts
    1,158

    Default

    Quote Originally Posted by djtim View Post
    I Am Having the exact same problem.
    only top left LED lights up.
    not nice flashing light boot up seq.
    just a brick right now.
    please advise on how to re flash or Reboot to got to factory default.
    cheers

    As I said, because the light is lit correctly after the lightshow the problem is in your host computer's USB setup. Check with this thread for information on making sure you have the USBAUDIO.SYS drivers correctly installed, and for the VID/PID numbers to search for and delete in your Registry:


    If you decide you do want to reflash your Midifighter (although I doubt it will do much more than give you a cool way to reset the factory defaults, which aren't the problem) you can follow the instructions here:


    Tell me what you find.

  9. #9
    Tech Wizard
    Join Date
    Jan 2010
    Location
    Shanghai
    Posts
    25

    Default

    I don't seem to get a light show. Well not like before anyway.
    before was a 1-16 button LED chase then a tiny flicker, then presto.

    now all i get is a tiny flicker from all Leds as i plug in and then the top left LED lights up. we are talking milliseconds. not like the boot up light show.
    I'm running a MAC BTW.

    Any ideas?
    Cheers

  10. #10
    Tech Guru Fatlimey's Avatar
    Join Date
    Mar 2008
    Location
    Redmond, WA
    Posts
    1,158

    Default

    OK, so that's new information! You don't get the power-on light show. Now we have something to work with. We should try and reflash the firmware.

    I have to update the "How To Flash Your Midifighter" instructions with Mac version, but here's the essentials (Thanks SarahEmm!) You will need to download the "dfu-programmer" command line tool from here:
    and the latest ".hex" firmware from the Midifighter sourceforge site:

    Then your steps are:

    1. Ensure you have the Apple Developer Tools installed (they come on a CD/DVD with new macs/new OSes)
    2. Install MacPorts. An installer can be found at http://www.macports.org/install.php.
    3. Open a Terminal window (found under /Applications/Utilities/Terminal) to get a command line.
    4. At the command line, run
      Code:
      sudo /opt/local/bin/port install dfu-programmer
      to build and install dfu-programmer and dependencies.
    5. Hold down the four corner buttons on your Midifighter and plug in the USB cable.
    6. At the command line, run
      Code:
      dfu-programmer at90usb162 erase &&
      dfu-programmer at90usb162 flash --debug 1 midifighter.hex &&
      dfu-programmer at90usb162 reset
      (without the linebreaks, where midifighter.hex is the name of the new firmware file to be programmed).
    7. Unplug and re-plug your Midifighter to start running the new firmware.


    If any of the "dfu-programmer" steps fail to connect to the Midifighter, your board is most likely borked and you need to drop a line to orders@djtechtools.com to find out what your options are.

    Try it out and tell me what you find.
    Last edited by Fatlimey; 05-24-2010 at 06:30 PM.

Page 1 of 5 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •