Mapping master clock to a fader
Results 1 to 6 of 6
  1. #1
    Tech Wizard
    Join Date
    Dec 2009
    Location
    Hamburg, Germany
    Posts
    22

    Default Mapping master clock to a fader

    Hey guys.

    Wanted to map the master clock to one of the faders on my Xone1D, however the range is set from 40-300 bpm which decreases the sensitivity greatly. The smallest movement of the fader changes the bpm by 3. Is there any way i can narrow the range and thereby increase the sensitivity of the fader? If this involved modifiers your gonna have to walk me through it haha. Cheers!

  2. #2
    Tech Guru
    Join Date
    Aug 2009
    Location
    Raleigh NC
    Posts
    985

    Default

    +1 I am interested in this as well.

  3. #3
    Tech Mentor Villinus's Avatar
    Join Date
    Jan 2010
    Location
    Berkeley, Ca
    Posts
    297

    Default

    I know on my MPD32, I can adjust the Midi note range of each fader/knob from 0 to 127.

    As an example, I was having an issue in Reason, where when I raised the fader all the way up, it brought Reason's fader up to +10db which was bad. So I adjusted the midi range of that one fader to go between 0 and 100, which magically brought Reason's fader to 0db!

    I don't have any solid modifier info, but if you can figure out how to adjust the sensitivity of a knob/fader on the VCI, or it's respective control in Traktor, you should have what you're looking for.

  4. #4
    Dr. Bento BentoSan's Avatar
    Join Date
    Mar 2008
    Location
    Perth, Australia
    Posts
    6,356

    Default

    Quote Originally Posted by Villinus View Post
    As an example, I was having an issue in Reason, where when I raised the fader all the way up, it brought Reason's fader up to +10db which was bad. So I adjusted the midi range of that one fader to go between 0 and 100, which magically brought Reason's fader to 0db!
    But then your dropping the resolution of the fader which makes the problem even worse. In Traktor what that would do is reduce the range of the tempo, but the resolution would still be an issue.

    What you gotta do is use the Relative mode trick.

    Type of controller - Fader/Knob
    Interaction mode - Relative

    Then adjust the rotary sensitivity and acceleration to your liking.

    Its not a perfect solution (cuz Traktors midi setup sux for setting minimum and maximum values) but it should work..

  5. #5
    Tech Wizard
    Join Date
    May 2009
    Posts
    21

    Default

    do you mean:
    type of controller - relative fader/knob and interaction mode direct?

    this works fine now, thanks Bento!

  6. #6
    Dr. Bento BentoSan's Avatar
    Join Date
    Mar 2008
    Location
    Perth, Australia
    Posts
    6,356

    Default

    Yeah thats probably it, i didnt have Traktor loaded up when i made that post, just going off memory.

    You get the jist though, its the same trick used to get an 8% pitch range over an internal 50% fader pitch range.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •