Tonearm causing static noises?
Results 1 to 4 of 4
  1. #1

    Default Tonearm causing static noises?

    Im receiving distorted-like static noise whenever i touch or move the tonearm of my LEFT turntable. Never had this problem before, it seems like a grounding problem. Both of my TT grounded to Rane SL-3 Box, everything seems to be in their place. Not sure where this problem is comming from, im sure it has to do with the tonearm. I tested by vibrating the turntable, tapping the vinyl, pushing and hitting this and that,, etc

    Just want to know if this is a common problem? where should i start fixing?
    should i replace the tonearm?

    I tried replacing/removing the cartridge, doesnt work either....
    im lost

  2. #2

    Default

    Update:
    Im getting noise just by placing the stylus on the vinyl while is stopped..

    this reminds me of when i first got my TT and I forgot to ground it.. this is really bothering me..
    please someone spare help

  3. #3
    Tech Guru josh@firestorm's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, Australia
    Posts
    1,627

    Default

    check the wiring of the tonearm, and the wiring of the cartridge.

  4. #4
    Tech Student
    Join Date
    Jun 2010
    Posts
    1

    Default

    are you lickin ur needles b4 u screw them in? those 4 posts on the end of the tonearm can get rusty n cause noise!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •