Midi-Fighter LED Help
Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1
    Tech Mentor jthompsn's Avatar
    Join Date
    Dec 2008
    Location
    Bardonia, NY
    Posts
    237

    Default Midi-Fighter LED Help

    Hey all-

    I received my MF today and got it loaded up with the Deckalized Deck Focus tsi. All of the buttons function correctly however the LED's do not.

    When a button is toggled to remain on the LED does not remain lit. They only light for the duration they are pressed regardless of toggling an effect ect.

    Also when placing the MF in cue point juggle mode (Shift + Sample) the eight bottom buttons do not stay on.

    I haven't made any changes and I believe my in/out setting are correct (all buttons do what they are supposed to do). Is there a way to get the proper visual feedback from the LED's like in Ean's MF video? Am i missing something?
    [Macbook 2.2ghz core 2, 4gb ram, 500gb 7200 Seagate Momentus HD, Western Digital 500gb external HD, Lion 10.7.2, Kontrol S4, Midi Fighter #67, Pioneer HDJ-2000, Traktor Pro 2

  2. #2
    Tech Guru Fatlimey's Avatar
    Join Date
    Mar 2008
    Location
    Redmond, WA
    Posts
    1,158

    Default

    Make sure you not only have MIDI input from the device but you have also enabled MIDI output to it. The LEDs are controlled by MIDI messages being sent out from your computer to the Midifighter.

    You can test this using MIDI-OX or a similar MIDI debugger by enabling the keyboard simulator and sending MIDI.

  3. #3
    Tech Mentor jthompsn's Avatar
    Join Date
    Dec 2008
    Location
    Bardonia, NY
    Posts
    237

    Default

    My in/out setting both list the MF. I'm not quite sure how to use MIDI-ox or the other debugger.
    [Macbook 2.2ghz core 2, 4gb ram, 500gb 7200 Seagate Momentus HD, Western Digital 500gb external HD, Lion 10.7.2, Kontrol S4, Midi Fighter #67, Pioneer HDJ-2000, Traktor Pro 2

  4. #4
    Tech Mentor jthompsn's Avatar
    Join Date
    Dec 2008
    Location
    Bardonia, NY
    Posts
    237

    Default

    If anyone who's LED's are functioning properly on their MF could post their setting in tractor I would appreciate it. Hope you guys can help!
    [Macbook 2.2ghz core 2, 4gb ram, 500gb 7200 Seagate Momentus HD, Western Digital 500gb external HD, Lion 10.7.2, Kontrol S4, Midi Fighter #67, Pioneer HDJ-2000, Traktor Pro 2

  5. #5
    Tech Mentor jthompsn's Avatar
    Join Date
    Dec 2008
    Location
    Bardonia, NY
    Posts
    237

    Default

    Quote Originally Posted by Fatlimey View Post
    Make sure you not only have MIDI input from the device but you have also enabled MIDI output to it. The LEDs are controlled by MIDI messages being sent out from your computer to the Midifighter.
    How do I do this? Where are the out settings? I'm sure the config in traktor controller settings are correct. I've done it at least 100x today. Still no LED function as per Ean's video.
    [Macbook 2.2ghz core 2, 4gb ram, 500gb 7200 Seagate Momentus HD, Western Digital 500gb external HD, Lion 10.7.2, Kontrol S4, Midi Fighter #67, Pioneer HDJ-2000, Traktor Pro 2

  6. #6
    Tech Student
    Join Date
    Jul 2010
    Posts
    3

    Default

    So I have a mac so I have MidiMonitor to determine what is being sent to/from Traktor to the MidiFighter.

    Here is the MidiMonitor output:

    Sync Off
    19:16:28.594 From Midifighter Note On 3 C#3 127
    19:16:28.679 From Midifighter Note Off 3 C#3 127
    19:16:28.681 To Midifighter Note Off 3 C#3 0

    Sync On
    19:16:38.456 From Midifighter Note On 3 C#3 127
    19:16:38.588 From Midifighter Note Off 3 C#3 127
    19:16:38.603 To Midifighter Note On 3 C#3 127

    The notes appear to be being sent right but my LED's aren't being set. I have confirmed that MidiFighter is set in both my In-Port and Out-Port in Traktor's settings.

    Here is my Traktor info for reference: Traktor Scratch Pro, 1.2.6. Mac OS X 10.6.4
    Last edited by zangfu; 07-15-2010 at 06:24 PM. Reason: More Details about my Traktor version.

  7. #7
    Tech Mentor jthompsn's Avatar
    Join Date
    Dec 2008
    Location
    Bardonia, NY
    Posts
    237

    Default

    I have to apologize for the noob panic, but thats what we noobs do...panic first think later.

    Just reflashed the MF firmware and my MFing MF is SWEET. All systems are go!!!!

    Thanks to all for their advice!
    [Macbook 2.2ghz core 2, 4gb ram, 500gb 7200 Seagate Momentus HD, Western Digital 500gb external HD, Lion 10.7.2, Kontrol S4, Midi Fighter #67, Pioneer HDJ-2000, Traktor Pro 2

  8. #8
    Tech Student
    Join Date
    Jul 2010
    Posts
    3

    Default

    I was just about to say the same thing. A re-flash did the trick. Just out of curiosity, is the new batch of MidiFighters using an older firmware?

  9. #9
    DJTT Super Moderator midifidler's Avatar
    Join Date
    Mar 2008
    Location
    San Francisco
    Posts
    1,905

    Default

    Sorry guys my bad there - when I programmed and tested them I managed to use an old version of the firmware which is a bit buggy around the LED contro, while they are now being reflashed before shipping from San Fran I believe some of the first units may have slipped through with the old firmware.

    What number units do you guys have?

  10. #10
    Tech Student
    Join Date
    Jul 2010
    Posts
    3

    Default

    Mine is 28/500.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •