Failing LED's
Results 1 to 4 of 4

Thread: Failing LED's

  1. #1
    Tech Convert
    Join Date
    Aug 2010
    Posts
    16

    Default Failing LED's

    Hi DjTechTools.

    I have had my VCI-100 for a couple of months now, it's great! Especially the new TSI, fixes some jog wheel issues i've had in the fader fx mode.

    Yesterday my right headphone cue LED wouldn't light when i pressed it. I restarted the computer, the controller, traktor, i had no clue what was going on. Then it came to my mind that ofc it was broken, doh. I thought okay what the heck i don't need it anyways.

    Today the same thing happened to the left headphone cue. I am starting to get worried now. How can you fix this? I am from Denmark so there's some distance.

  2. #2
    Tech Convert
    Join Date
    Aug 2010
    Posts
    16

    Default

    Bump - Please where can i get it fixed?

  3. #3
    Tech Convert
    Join Date
    Aug 2010
    Posts
    16

    Default

    bump

  4. #4
    DJTT Infectious Moderator photojojo's Avatar
    Join Date
    Apr 2010
    Location
    Sherman, TX
    Posts
    13,939

    Default

    You might try finding an electronic repair place locally and take it to them. Might help if you could take the VCI apart beforehand. If you can solder it's not that hard of a fix. if you can't solder go to radio shack and get a desoldering iron and a hand full of LED's. Then go to a thrift store like goodwill or salvation army and buy something with lots of LED's in it. Take it apart and practice replacing LED's. When you feel like you've gotten good enough at it to not screw up your VCI have at it.
    Chris Jennings FHP

    Podcast - Soundcloud - Mixcloud - Beatport Charts - x

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •