Technics n00b
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Technics n00b

  1. #1
    Tech Wizard
    Join Date
    Jul 2010
    Location
    DC
    Posts
    20

    Default Technics n00b

    Yo djtt forums, I got a problem. I got my techs yesterday and picked up my m447s, but it's being a bit odd on my record. Ive never used tts before, but my height is set at 0 the arm is balanced and is floating, anti skate is set at 0. The needle sits flush with the headshell. My balance is not backwards and the traking force is set at 2.5. When I put the needle on the record, you can hear like a scraping noise and the audio is choppy and staticy. Btw record is ub40 labour of love seriously though, help me out. Thanks!
    Current Setup:
    A&H XoneX + Serato Itch + MBP 13inch + Ortofon O-One

    Soon To Be Setup:
    A&H Xone: DX+Technics 1210 M5G + Traktor Scratch Pro + MBP 13inch + Ortofon O-One

  2. #2
    Tech Guru Ross's Avatar
    Join Date
    Jul 2010
    Location
    Bournemouth, UK
    Posts
    1,155

    Default

    Might be a stupid question, but have you grounded it properly?
    Pioneer DJM 700 / Traktor Kontrol X1 / 2 x Technics SL1200MK5 / Traktor Scratch Pro 2.6.7 / Ortofon Concorde Nightclub MK1
    Audio 8 DJ / Sennheiser HD 25-1 II / Magma Traveler / IsoAcoustics ISO-L8R155 / KRK RP6 G2 / Vinyl

  3. #3
    Tech Wizard
    Join Date
    Jul 2010
    Location
    DC
    Posts
    20

    Default

    Yea, on the back of the one dx there's a post for the ground wires. I put em both there
    Current Setup:
    A&H XoneX + Serato Itch + MBP 13inch + Ortofon O-One

    Soon To Be Setup:
    A&H Xone: DX+Technics 1210 M5G + Traktor Scratch Pro + MBP 13inch + Ortofon O-One

  4. #4
    Tech Student
    Join Date
    Sep 2010
    Posts
    1

    Default

    Have you tried using another record?

  5. #5
    Tech Guru farhanashraf's Avatar
    Join Date
    Mar 2010
    Location
    Dubai, UAE
    Posts
    1,780

    Default

    make sure u follow this first:

    http://www.youtube.com/watch?v=vDRQfnQfb4w
    Quote Originally Posted by theory28 View Post
    iatf = in after the farhanashraf
    Quote Originally Posted by theory28 View Post
    its ibtf! iatf is too easy to get!
    who we r
    what we have done

  6. #6
    DJTT Infectious Moderator photojojo's Avatar
    Join Date
    Apr 2010
    Location
    Sherman, TX
    Posts
    13,939

    Default

    Dude needs a haircut.
    Chris Jennings FHP

    Podcast - Soundcloud - Mixcloud - Beatport Charts - x

  7. #7
    Tech Guru
    Join Date
    Aug 2010
    Location
    Northern Ireland
    Posts
    1,145

    Default

    is the tracking force for the m447's deffo 2.5g? were the carts new or 2nd hand? Stylus could need replaced. I'm guessing you bought two, have you tried them both?

    It would also be worth taking the headshell off the tonearm and looking into the socket, do the brass contacts appear dark? if so theres a buildup of mild corrosion, a wee scrape with a fine screwdriver will sort it
    Traktor Scratch Pro 2.7, MBP 13", iPad 2 & TouchOSC, Reloop NEON, Pioneer DJM750mk2, Mackie d.2, Pioneer CDJ800 x2, Technics SL1210MK2 x2, NI Audio 6 DJ, Dicers,

  8. #8
    Tech Wizard
    Join Date
    Jul 2010
    Location
    DC
    Posts
    20

    Default

    sorry for the late reply. I tried balancing the arms again, one of them worked. tried another record, worked with the same one but not with the other. I took the cart from the working one to the non working one, and still, audio is distorted. what could it be? is it possible i balanced the arm wrong? I looked in the sockets, but they look brand new. Not a surprise as i bought them new lol. I also moved the "bad" cart to the working table and it sounded a little distorted. could it be the needle? I bought them both new
    Current Setup:
    A&H XoneX + Serato Itch + MBP 13inch + Ortofon O-One

    Soon To Be Setup:
    A&H Xone: DX+Technics 1210 M5G + Traktor Scratch Pro + MBP 13inch + Ortofon O-One

  9. #9
    Tech Guru Patch's Avatar
    Join Date
    Dec 2008
    Location
    Bristol, UK
    Posts
    6,411

    Default

    Best thing to do is take both headshells of the tonearm, strip 'em down, and re-build 'em. Clean up the connections on the headshell, and take a look at the wires between the cart and the headshell.

    Could even be that you've got one of the wires incorrectly connected (the 4 coloured wires have to go to specific connections on the headshell).
    DJ'ing: 2x1200MK2, DJM 850, Dicers, F1, Zomo MC-1000, Sony MDR-v700, i7 Win 10 HP Envy
    Production: Ableton Live 8 and a mouse, Sennheiser HD400, Sony VAIO

    Click HERE to D/L Free Tracks from Soundcloud!!!
    https://www.facebook.com/Patchdj

  10. #10
    Tech Wizard
    Join Date
    Jul 2010
    Location
    DC
    Posts
    20

    Default

    i tried that as well, but i just realized that it was always my right tt. so after further inspection, bot the needles are fine, but its just the right tt making the noise. what could it be? i bought the tts new so idk. PLEASE HELP!!!!!!! im super stressed out, i dropped all this cash and this thing is being stubborn. AHHHHHHH
    Current Setup:
    A&H XoneX + Serato Itch + MBP 13inch + Ortofon O-One

    Soon To Be Setup:
    A&H Xone: DX+Technics 1210 M5G + Traktor Scratch Pro + MBP 13inch + Ortofon O-One

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •