unboxed vci 100se
Results 1 to 2 of 2
  1. #1

    Default unboxed vci 100se

    hey everyone, i unboxed the vci 100se yesterday and i was extremely excited to start using it. but when i plugged it into my one week old 13'' macbook pro, none of the lights even turned on..): then i tried it again and a message popped out saying that "one or more usb devices was taking up too much power and the usb port was disabled". i tried it then with a power supply but my vci still wont even turn on.. i have never even seen its lights turn on; i tried this on my windows hp laptop but the device still wont turn on..
    someone please help!

  2. #2
    Tech Mentor ZachDero's Avatar
    Join Date
    Feb 2009
    San Francisco


    Give me a call on Monday and I can help you troubleshoot.
    877 246 8958

    Also try opening up the back case, and make sure that there is a piece of black cardboard (white in the video) covering a PCB. To open the back case, check out this video:

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts