Need help with new setup (traktor scratch pro & x1 controller)
Results 1 to 3 of 3
  1. #1

    Default Need help with new setup (traktor scratch pro & x1 controller)

    Hi guys.

    I've just purchased a new mac, traktor scratch pro & the x1 controller and I'm having a nightmare trying to set it up.

    As soon as I got the mac i updated its software so everything is up to date there. After i installed the scratch pro & x1 software i updated that too through the "Service centre." I also registered both products.

    Now as far as I'm aware you need scratch pro version 1.2.4 or over for the x1 controller to work. So, I downloaded version 1.2.7 and went through the installion peocess and everything seemed fine. I restarted the mac as requested. When i opened scratch pro and checked the version is was still the original installed version (1.2.2). I tried to reinstall the update again and it seemed to work, until i re checked the version and it was still 1.2.2. So, I uninstalled all of the traktor & x1 software and reinstalled it again, however the exact same thing happened.

    The x1 controller flashes for a second or two when I connect it to the mac then it goes blank. The hotcue & shift keys also light up when pressed but nothing else seems to work. If I turn the knobs nothing happens in traktor other than the midi symbol (top centre) flickers, however none of the other virtual buttons work.

    I had a quick look in control manager and under "device" the only thing listed is "Generic keyboard device." I'm assuming the x1 should be listed here if its installed correctly.

    I've been at this for 3 days solid at this stage and it's really fustrating that i cant get my new toys to work! Any help would be greatly appreciated.

    Thanks guys
    Jonny

  2. #2
    Tech Wizard
    Join Date
    Nov 2009
    Location
    Derry, North of Ireland
    Posts
    72

    Default

    Stick this into general discussion mr delaney. More people will see it

  3. #3
    Tech Guru
    Join Date
    Feb 2010
    Location
    Desert Hot Springs, CA
    Posts
    763

    Default

    hmm...
    have you tried adding the device to traktor's list yourself?

    open your preferences (icon looks like a flywheel or somethin)

    click the controller manager tab

    then at the top click ADD and try importing the tsi
    or even adding it as a generic midi device.

    Hopefully this helps with something in your discovery!
    Hardware: Akai Max49, Maschine, Equator D5 monitors, Saffire Pro 14
    Software: Logic, Maschine
    My Neighbors Listen to House Music.. Because They Have To.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •