Traktor Pro + MacBook Pro not working correctly
Results 1 to 4 of 4
  1. #1
    Tech Convert
    Join Date
    Nov 2010
    Location
    Edinburgh, UK
    Posts
    7

    Default Traktor Pro + MacBook Pro not working correctly

    Hi everyone,

    I know this is a big problem with many possible solutions but I thought I'd give it a go here since I'm at my wits end with trying to solve it.

    I have a MacBook Pro Intel 2.26GHz with 4 gigs of ram, Hercules Steel, NanoKontrol and am using an M-Audio Fast Track Pro interface. After installing Traktor Pro everything worked great initially and worked so consistently for a couple of weeks. Traktor would start up instantly when I clicked on it and I even managed to make a recording.

    Now however, Traktor takes 5+ minutes to load up (it will always display as 'Not Responding') and it won't recognize any of my controllers anymore even if I reload their .tsi files. If I use the mouse and drop in a music file, traktor will play it and audio does come out of my speakers.

    Any help? In between using Traktor when it worked and now as it doesn't, I did change a number of audio preferences in the M-Audio box for use with Pro Tools when I did some recording. However, I am completely certain I changed all things back, I even did a trial and error trouble shooting by adjusting each variable individually to see if there would be any difference. I've swapped USB bus ports for the interface and USB hub thinking it may have something to do with data transfer speeds.. no luck there.

    Aside from deleting and reinstalling Traktor Pro, any tips/advice for things to try? My Midi Fighter comes in about a week and this is so frustrating!

    Lastly, I hope this is the correct forum for this! If it isn't, mods, could you please move?

    Thanks in advance.

    Warmest wishes,
    Colin

  2. #2
    Tech Guru
    Join Date
    Aug 2010
    Location
    Northern Ireland
    Posts
    1,145

    Default

    what version of traktor?
    Traktor Scratch Pro 2.7, MBP 13", iPad 2 & TouchOSC, Reloop NEON, Pioneer DJM750mk2, Mackie d.2, Pioneer CDJ800 x2, Technics SL1210MK2 x2, NI Audio 6 DJ, Dicers,

  3. #3
    Tech Guru MaxOne's Avatar
    Join Date
    Jan 2009
    Location
    London, UK
    Posts
    2,920

    Default

    Tried updating Traktor?
    CLUB OF JACKS - RELEASES >>TRAXSOURCE
    Club of Jacks are a London based House & Garage production / DJ duo with releases on a number of underground labels including Plastik People Recordings, Blockhead Recordings, Hi Energy!, Pocket Jacks Trax, Soul Revolution Records and their own Club of Jacks imprint.

  4. #4
    Tech Convert
    Join Date
    Nov 2010
    Location
    Edinburgh, UK
    Posts
    7

    Default

    Version 1.2.7

    Update.

    I'm an idiot. My fault everyone, hopefully people can learn from my dumb mistake here.

    I teach school children part time and have to clean up my desktop when I use my computer. I placed the nanokontrol and Steel .tsi files into a different folder and didn't put them back to their original locations (in a folder on the desktop) I kept looking at where the original Traktor destination was..thinking it was a traktor problem...grrrr. Now all is back to normal, Traktor starts right up (I assume because it isn't scanning in attempts to find the controller file location?) and the controllers all work just as they did before.

    Sorry guys! I'm just so relieved that things are working again! Whew! Now back to mixing

    All the best,
    Colin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •