broken sensitivity dial broken - jog issues
Results 1 to 5 of 5
  1. #1
    Tech Mentor
    Join Date
    Dec 2008

    Default broken sensitivity dial - jog issues

    Hi , like others I am sure, I have broken the variable resistor at the back of my unit that adjusts the sensitivity for the jog wheel . Does anyone know the part # / resistance / manufacturer?

    Also, leading up to me breaking the dial, i was not able to get the right jog to respond to my touch (using all settings from min to max at the back of the dial), and the light of course was very intermittent, where as the left jog while I tapped and untapped no matter what speed the light would go on and off with each tap and of course the response of the platter was OK. The jog rotates ok, no stiffness or grinding etc.. by following DIY repair guide do you think i am able to fix this this issue?

    Oh while the the jog LED and the response was not working the data light always lit up to the touch... maybe this might spark some ideas.

    -1.4 firmware
    -TP 1.2.7
    -3.6.4 TSI

    In the mean time, I would still like to use the unit.. when scratch mode is turned off , i can use the jog for pitch bend ok (for the most part), but seeking through a track is slow and painful, where as the working jog on the left seeks fast through tracks when the scratch mode is either on or off. How can I speed the right jog up ? Does this rely on the touch sensor ?

    Thank you! hope this post was not to long, but I wanted to paint a full picture of my problem
    Last edited by NewManSoon; 02-14-2011 at 06:48 AM. Reason: title

  2. #2
    Tech Student
    Join Date
    Oct 2009


    I have the same problem with NewManSoon.When i touch the jog wheel, the light does not respond my touch ( the lights is still blue, sometimes it's red but very intermittent ). I tried to adjust the sensitive at the back but it doesn't work.
    Also i tried to follow the DIY repair guide, i checked the rotary post , optical encoder , ground finger and the plastic guard.Everything looks fine but the red light wasn't on when i touched the jog wheel.
    -1.3 Firmware
    -Traktor Pro 1.2.4
    -Macbook Pro
    Could some body help me ??

  3. #3
    Tech Mentor
    Join Date
    Dec 2008

    Default Update

    Ok, I have replaced the sensitivy pots on the back. I have the right jog now responding to touch, but , in the software (scratch mode only) , the scratching really lags , and is inconsistent. If I turn scratch mode off, and the music is "paused" , i can seek through the track with no problems.

    For shits and giggles, I took apart the VCI and removed the connectors that go from the jogs to the circuit board (2 for each , the "sensor / finger" wire and the coloured wires that connect to the "optical reader" - the thing that the disc passes through) and connected the WORKING left jog to the connectors for the right deck. So now the left jog uses the sensitivity sensor and mappings for the right (non working) deck. Sure enough, the left deck is still working as it should. So I think it is safe to say I can rule out the mappings and sensitivity dial.

    Any suggestions? I am thinking something physically wrong with the jog it self. I will be trying the deoxit stuff in between the shaft and finger. Other then that I am lost.

  4. #4
    Tech Mentor
    Join Date
    Dec 2008


    I blew the optical reader (lightly) as well as the disc is now working as it should.

    Also , my left "hi" eq that was bouncing all over is now working , the deoxit worked.

    Yay , a working VCI-100.

    If anyone is having problems with theirs , these things are ridiculously easy to take a part and troubleshoot. Don't be afraid to swap things around (such as the optical reader, disc etc..) , to rule out different pieces that could be causing trouble.

    Thanks for all the suggestions I received. Good luck!

  5. #5
    Tech Convert
    Join Date
    Apr 2011

    Default hi

    Hi NewManSoon...
    Hopefully you can help me since I seem to have the same problem. So my sensitivity was really sporadic on the left platter while the right platter was really sensitive and for the most part worked as should... So i tried to dial in the sensitivity adjustment and lo-and-behold...*SNAP* ----broke the dial right off! I tried to open the VCI hoping somehow I could snap it back on. Unfortunately I couldn't and now I'm looking through this forum trying to find others who posted similar as mine before I made a new thread... Found yours and totally hoping you may help me get mine working like yours!

    ---you said you 'deoxit'... could you explain what you did that got yours working?

    ---and also you mentioned you replaced the 'sensitivitiy pots' in the back... is this refering to the sensitivity dial? I really hope it is since the only solution I could think of was to find the nearest service repair and was getting prepared to get hit in the wallet pretty bad! lol

    Thank you and hope you or any others that can help me out! Cheers!


    UPDATED: just read your other posts to another person who had the same problem... and found my answer to the deoxit question. I also read that you upgraded the sensitivity dials to better ones... could you give me some details on that a little more? thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts