Strange X1 Problem
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    DJTT Tankard fullenglishpint's Avatar
    Join Date
    Aug 2010
    Location
    St Albans, UK
    Posts
    7,101

    Default Strange X1 Problem

    Had a weird problem last night.

    I'm using my X1 with an edited NHL mapping.

    Plugged it in and it was working almost normally, though LED feedback was a bit buggy, but then the LEDs froze and it stopped working. Reset it a few times and it came on with the shift button permanently illuminated and nothing responding.

    I looked into my controller mappings and discovered that it had automatically added a second X1 NHL mapping, the default NI one, at the end of the list. I deleted that, reset the X1 and the same thing happened again. A new default mapping popped up. Very confused, I looked at the in/out settings on my own mapping and discovered that there were two X1 options, implying that there are 2 X1s plugged in... yet I definitely only have 1!

    Selecting the second one and deleting the automatically created mapping made it work as normal, but resetting the controller made the problem happen again and in fact at one point it just seemed to reset itself.

    Any ideas as to why that would happen? I didn't try restarting Traktor because I was in the middle of a big b2b session with my mate, then I forgot about it, so it's entirely possible that would fix it lol. Just confused as I've never seen or heard about this problem before.
    TSP 2 | Serato DJ | Live 8 | MBP (SSD + HDD) | AIAIA TMA-1 Fool's Gold Edition | 1200 Mk2s | MidiFighter | KRK RP5
    Xone: DB4 | Pioneer CDJ-2000 Nexus
    DJTT FAQ | Read my guide to AUDIO CABLES

  2. #2
    Tech Mentor ponyboy's Avatar
    Join Date
    Apr 2009
    Location
    London, home of the Pony.
    Posts
    492

    Default

    should have bought a mac.
    Tony the Pony.
    My soundcloud page. House, mainly.

    Mixcloud & Website coming soon.

  3. #3
    Tech Mentor ponyboy's Avatar
    Join Date
    Apr 2009
    Location
    London, home of the Pony.
    Posts
    492

    Default

    Quote Originally Posted by ponyboy View Post
    should have bought a mac.
    Oops, wrong thread :[]
    Tony the Pony.
    My soundcloud page. House, mainly.

    Mixcloud & Website coming soon.

  4. #4
    DJTT Tankard fullenglishpint's Avatar
    Join Date
    Aug 2010
    Location
    St Albans, UK
    Posts
    7,101

    Default

    lol, nice one!
    TSP 2 | Serato DJ | Live 8 | MBP (SSD + HDD) | AIAIA TMA-1 Fool's Gold Edition | 1200 Mk2s | MidiFighter | KRK RP5
    Xone: DB4 | Pioneer CDJ-2000 Nexus
    DJTT FAQ | Read my guide to AUDIO CABLES

  5. #5
    Tech Guru JonathanBlake's Avatar
    Join Date
    Dec 2010
    Location
    Johannesburg, South Africa
    Posts
    2,610

    Default

    Had EXACTLY the same sequence of events when I tried using a USB3.0 port. Never had it again since only using USB2.0.

  6. #6
    DJTT Tankard fullenglishpint's Avatar
    Join Date
    Aug 2010
    Location
    St Albans, UK
    Posts
    7,101

    Default

    Quote Originally Posted by JonathanBlake View Post
    Had EXACTLY the same sequence of events when I tried using a USB3.0 port. Never had it again since only using USB2.0.
    odd... was it fixed by restarting traktor?
    TSP 2 | Serato DJ | Live 8 | MBP (SSD + HDD) | AIAIA TMA-1 Fool's Gold Edition | 1200 Mk2s | MidiFighter | KRK RP5
    Xone: DB4 | Pioneer CDJ-2000 Nexus
    DJTT FAQ | Read my guide to AUDIO CABLES

  7. #7
    Tech Guru JonathanBlake's Avatar
    Join Date
    Dec 2010
    Location
    Johannesburg, South Africa
    Posts
    2,610

    Default

    Fortunately was not gigging - just 'twiddling'. Shut down Traktor, restarted, never happened again. Did you also find that shift seemed 'brighter' than usual?

  8. #8
    DJTT Tankard fullenglishpint's Avatar
    Join Date
    Aug 2010
    Location
    St Albans, UK
    Posts
    7,101

    Default

    yes!
    TSP 2 | Serato DJ | Live 8 | MBP (SSD + HDD) | AIAIA TMA-1 Fool's Gold Edition | 1200 Mk2s | MidiFighter | KRK RP5
    Xone: DB4 | Pioneer CDJ-2000 Nexus
    DJTT FAQ | Read my guide to AUDIO CABLES

  9. #9
    Tech Guru JonathanBlake's Avatar
    Join Date
    Dec 2010
    Location
    Johannesburg, South Africa
    Posts
    2,610

    Default

    .....spooky.....

  10. #10
    DJTT Moderator Dude Jester's Avatar
    Join Date
    Feb 2009
    Location
    New Zealand
    Posts
    12,333

    Default

    Curiouser and Curiouser.
    Acer E5 i7 2TB 16GB ~ 512GB SSD ~ WIN 10 ~ TSP 2.11 ~ AUDIO 6 ~ X1 ~ DN-X1600 ~ X1 ~ SPECTRA ~ TWISTER ~ ATH-PRO500 MK2 ~ AT2020 MIC

    "This aggression will not stand, man."

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •