Traktor Scratch Duo 2 Skipping/Static sound
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1

    Default Traktor Scratch Duo 2 Skipping/Static sound

    I recently upgraded to Traktor Scratch Duo 2 and I seem to have encountered a terrible problem. While using timecode vinyl my tracks seem to skip and have a crazy fuzzy static sound to them during a mix. This problem seems to happen randomly, but most often when i am pulling the record back and forth. I thought it was a timecode issue, but i have changed timecode records AND needles on my turntable and them problem is persisting. It even happens when I have the deck set to not be controlled by the timecode. ANYONE experiencing this problem? PLEASE HELP

  2. #2
    Tech Wizard
    Join Date
    Mar 2011
    Location
    Florida
    Posts
    31

    Default

    Is your keylock on? Is it in high quality mode? Some people over on the NI forums were indicating that going to eco. mode helped with a similar sounding issue. You might also want to try upping your latency a little and seeing if that helps?

  3. #3

    Default Key lock

    My key lock is on hiQ mode. Going to switch to eco mode when I get home from school and see if it helps. Praying to the DJ gods that this helps cuz I do not want to switch back to Traktor 1 and loose my sample decks

  4. #4
    Retired DJTT Moderator DvlsAdvct's Avatar
    Join Date
    Mar 2008
    Location
    New Jersey/NYC
    Posts
    4,826

    Default

    Also try upping your latency
    It's the FAQ. Read it.

    My Mixes, Mashups and Rants

    Divided we stand
    United we fall

  5. #5

    Default

    My latency is set at 512, What would you suggest upping it too?

  6. #6
    Retired DJTT Moderator DvlsAdvct's Avatar
    Join Date
    Mar 2008
    Location
    New Jersey/NYC
    Posts
    4,826

    Default

    Your audio latency in Traktor is 512? You sure? That really doesn't sound right. Your latency should be measured in milliseconds
    It's the FAQ. Read it.

    My Mixes, Mashups and Rants

    Divided we stand
    United we fall

  7. #7

    Default

    Latency is 14 milliseconds. says 512 next to latency and above the milliseconds, not sure why. the milliseconds changes as the "512" number changes. What is a good setting in milliseconds?

  8. #8
    Tech Wizard
    Join Date
    Mar 2011
    Location
    Florida
    Posts
    31

    Default

    512 with my built in sound card (old MBP) is 6ms, 6.5ms, 12ms, or 13.1 depending on the sample rate... I would have thought an Audio 4/6/8/10 would have made that lower?

  9. #9
    Tech Mentor The Progen's Avatar
    Join Date
    Aug 2010
    Location
    Malaysia
    Posts
    125

    Default

    Quote Originally Posted by D_G_ View Post
    Is your keylock on? Is it in high quality mode? Some people over on the NI forums were indicating that going to eco. mode helped with a similar sounding issue. You might also want to try upping your latency a little and seeing if that helps?
    Thank you so very much for this. With Traktor Pro on my two notebooks, it used to be on Eco mode but when I imported the settings created on my desktop (was on the HQ mode there), I didn't notice this at first and was getting frustrated because just about every setting less than 16ms resulted in glitches. My cheapo self assembled desktop with a cheap ESi Maya44 PCI soundcard does 2.9ms happily in HQ mode with no glitches. That was why I forgot about it. Thanks again!
    Know thy music ...

  10. #10

    Default

    I am at school so im only able to see the settings for the bulit in sound card being that my Audio 4 is at home. Latency is prolly different i will post back with the actually latency with the audio 4 connected asap

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •