ACPI issues and latency - help please!
Results 1 to 6 of 6
  1. #1
    Tech Wizard
    Join Date
    Nov 2008
    Posts
    70

    Default ACPI issues and latency - help please!

    Hey guys,

    So I just picked up a new Lenovo Ideapad y560p and so far I'm really enjoying it. I'm running Windows 7, and was getting minor latency spikes in the neighborhood of 400-500 every 15 seconds. When I pulled the battery out, those spikes went away and latency hovered around 50-100. So I disabled the ACPI battery device in the Device Manager and things seemed cool for a while.

    I just installed Win 7 SP1 this morning and it appears the problem is back, whether or not I disable the ACPI battery device. I checked msconfig, and it seems like SP1 added a metric ton of new services, which I'm not okay with, but they don't seem to be the source of the problem.

    When I pull the battery, the spikes go away again. The spikes are smaller (~300) but more frequent now (every ~5 seconds).

    Any idea what I should disable to stop these spikes and ensure that my latency is as smooth as possible?

    Thanks, guys!

  2. #2
    Tech Guru
    Join Date
    Mar 2008
    Location
    Seattle, WA
    Posts
    1,448

    Default

    I would consider that spike totally acceptable. No way I would go digging around for it personally unless I knew what it was immediately and had an easy fix.

    The ONLY spikes you should care about are the ones that bring you into the red. And it's flawed logic to assume that a small spike will turn into a big spike when DJing. That's not how it works.

  3. #3
    Tech Wizard
    Join Date
    Nov 2008
    Posts
    70

    Default

    Quote Originally Posted by nem0nic View Post
    I would consider that spike totally acceptable. No way I would go digging around for it personally unless I knew what it was immediately and had an easy fix.

    The ONLY spikes you should care about are the ones that bring you into the red. And it's flawed logic to assume that a small spike will turn into a big spike when DJing. That's not how it works.
    Yellow I shouldn't worry about either? Huh. Interesting.

    I just remember you bragging once that you brought a Lenovo down to 80 microseconds latency or something else similarly crazy and I kind of wanted to see if I could pull that off.

    I'm having some trouble with my SCS.1s (scratchy crunchy audio in TP2) but Drew's working with me on that issue.

  4. #4
    Jack Bastard
    Guest

    Default

    Go into your Win7 power settings, create a new profile with every single power saving measure disabled, also try using Gamebooster.

  5. #5
    Tech Guru
    Join Date
    Mar 2008
    Location
    Seattle, WA
    Posts
    1,448

    Default

    Yellow I shouldn't worry about either? Huh. Interesting.
    If it's just an occasional yellow spike, and your audio application is running fine, then it's not a big issue. I don't know that I would go chasing down a green spike unless I knew I could do so without sacrificing anything functionality-wise. A lot of these "solutions" might work to kill the spike, but can be problematic in the long run. A great example of this is disabling ACPI. Sure, it's a wide sweeping fix. But it also often renders your thermally controlled fans braindead, which can cause heat issues.

    You have to measure the effort against the performance.

    Those Lenovos I got down to the teens (teens sir, not 80) I did to see if I could. It was a challenge to see how far I could go. But it's not something I do to my normal computers. I tweak them down until I have no problems, then I stop.

  6. #6

    Default

    Hi guys, I've had my lenovo for a couple of months now and have been having the same letency spike problem! I record music on cubase and have been having dropouts since I bought the laptop. I managed to find one of the culprits last month which was my wireless networking card which was causing 5 secs of 5000 every minute. Once I disabled that the situation improved but there were spikes of upto 1000 every 15 seconds that I could not find until I found this thread today.

    By simply disabled the ACPI it has completely flattened the latency to 50-100! I am yet to try some recording but hope it solves the issue. I will just make sure I enable the ACPI each time I finish my sessions.

    Nick

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •