I have a weird ableton question
Results 1 to 6 of 6
  1. #1

    Default I have a weird ableton question

    TL;DR: How I can get ableton to only play one clip at a time regardless of its placement in session view?

    Hey everyone,

    I'm using ableton as a midi controller for a fire cannon rig. Basically, each note corresponds to a cannon and sending that note over midi will cause it to fire. I've got some clips made with cool patterns and stuff and launch them from the session view.

    Originally what I was doing was putting clips into different tracks based on what type they were. I was able to play a clip in one track and then play a clip in another track and the first one would automatically stop when the second clip was triggered.

    The problem is that now Ableton won't stop the old clip when a new one starts playing. I'm not sure how it happened but its turning into a big problem. So far my only solution has been to dump them all into one track but I really have too many clips to make that a permanent solution.

    A solution that I thought of but haven't figured out how to implement was to solo the track that has the clip I want to play but I'm not sure if theres a way to make a macro or anything for that.

  2. #2
    Tech Mentor rhombus_77's Avatar
    Join Date
    Oct 2010
    Location
    Tucson, AZ
    Posts
    458

    Default

    hmmm, are you using Follow Actions? Check this out:

    http://www.cosm.co.nz/index.php?opti...&catid=20:news

    Hope that helps or gets you closer to solving your problem.
    PC | TSP2 | A8 | S4 | X1 | T1200MK2

    Beat Gridding Tutorial

  3. #3
    Tech Guru TommyQuiet's Avatar
    Join Date
    Oct 2009
    Location
    NorthWest,UK
    Posts
    1,440

    Default

    yeah just use follow actions.

  4. #4

    Default

    Sorry to bump my old thread but I'm still looking to resolve this. Follow actions aren't what I need to do. Basically the end result is that I need only one clip playing at a time regardless of what column it is in. So if something in column 1, row 1 is playing and I trigger a clip in column 2, row 1 the first clip will immediately stop playing.

    Follow actions do not work this way and I've been toying around with doing some odd midi mapping stuff but its really not working out as intended.

    Really all I want to do is to have one clip playing at a time ever. When one clip begins playing all others immediately stop. Thoughts?

  5. #5
    Tech Guru Bassline Brine's Avatar
    Join Date
    Jan 2010
    Location
    Massachusetts
    Posts
    1,818

    Default

    Put them all in one column.

    Otherwise I understand what you are getting at, but I don't know how to do it. Nor would I personally want to, but there has got to be a way.
    BREAKBEATS AND OTHER MUSICAL ADVENTURES
    Facebook - Soundcloud - Mixcloud - Mixlr - Twitter

  6. #6
    Tech Mentor Kid Quest's Avatar
    Join Date
    Feb 2010
    Location
    Chicago, IL
    Posts
    120

    Default

    You can try to group all the tracks and organize everything so that no two clips are in the same row. This way you can have clips in multiple tracks and just click on the play button on the master group track. This will stop any clips playing on other channels if. I don't think this is easier than using follow actions and putting them all in the same column as Bassline Brine suggested. If that is not a viable option for you though, this may be your only option.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •