Changing Firmware Windows > Mac
Results 1 to 4 of 4
  1. #1
    Tech Convert [I/O]'s Avatar
    Join Date
    May 2011
    Location
    Miami, Fl
    Posts
    14

    Question Changing Firmware Windows > Mac

    hey guys.
    so a friend of mine has lent me his VCI-100 SE for the summer while he's out of town, and i'm having a bit of trouble setting it up. i'm a bit new to midi (in djing, in production i've never had an issue), but what i've deduced the problem is the fact that the VCI's firmware is the Windows firmware, and i need the Mac firmware (as i am a Mac owner). i've read Ean's tutorial, but for some reason i'm having trouble using that tutorial to make a cross-platform firmware switch. anyone have/figured out this issue that could provide me some help and/or a solution? i'd love to bring this with me when i'm traveling for gigs/pleasure to do a little bedroom mixing/jamming with friends rather than bringing some of my more bulkier gear. thanks for the help, i really wanna make some use out of this thing, i've messed with em before and they're so much fun!

    http://bionicbeatlab.org
    music is the soul of the universe

  2. #2
    DJTT Infectious Moderator photojojo's Avatar
    Join Date
    Apr 2010
    Location
    Sherman, TX
    Posts
    13,939

    Default

    I'm a little confused with what you're trying to do. Are you trying to update the firmware by taking it apart and using the update chip? You can only do that with Windows; I did it with Windows in Bootcamp, but you still need Windows. If the latest (or any for that matter) firmware is installed it'll work on both Windows and Mac.
    Chris Jennings FHP

    Podcast - Soundcloud - Mixcloud - Beatport Charts - x

  3. #3
    Tech Convert [I/O]'s Avatar
    Join Date
    May 2011
    Location
    Miami, Fl
    Posts
    14

    Default so yeah.

    like i said, i'm a bit of a midi noob. i took the panel off of it and it looks like its on 1.2 as it doesn't have any hardware upgrades. i'm fine with that, but the damn thing won't do anything on a mac. won't turn on, send midi signal, anything. when i plug it into my work computer (HP desktop running windows 7) though, it lights up and is detected immediately. this is the issue i'm having. i'm considering just getting the update chip and doing it that way, but i was wondering if there was a software fix before i go on this DIY journey

    http://bionicbeatlab.org
    music is the soul of the universe

  4. #4
    Tech Mentor
    Join Date
    May 2011
    Location
    Minneapolis MN
    Posts
    172

    Default

    the vci-100 looks the same inside wether its 1.1, or 1.4 fw. do you have the right mapping?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •