Vestax Typhoon w/ Traktor LE : Device not recognized by traktor
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    Default Vestax Typhoon w/ Traktor LE : Device not recognized by traktor

    Hi everyone,

    I've stopped counting the hours that I tried to fix this and I hope someone will be able to help. I'm desperate

    This is no my first midi controller, I even had it installed on my previous pc and it worked fine. Even, the first time I connected it (after installing the drivers) it worked and after that never worked again.

    I connect my device then open traktor but it doesn't seem to recognize the controller, beside Asio for Typhoon driver it says "not connected" and impossible to make it connect. At the bottom it says "Please connect and select an audio device"

    I use Windows 7, I have an acer laptop with i5, 8gb ram so it should run it without any issues.

    I tried to reinstall the driver many times (asio for typhoon), reinstall traktor, use all my usb ports, didn't try to reinstall windows yet

    I have something called dolby advanced audio and Realtek HD audio manager on my pc, could that be interferring?

    Please help!

    Thanks for reading
    ---
    ohhh and I also checked a huge amounts of threads and forums but nothing helped so far

  2. #2

    Default

    If you need a screenshot or any other info to help me please ask.

    I need to make this work

  3. #3
    Tech Guru Sherlock Ohms's Avatar
    Join Date
    Jun 2009
    Location
    Bristol, UK
    Posts
    1,596

    Default

    Does the Typhoon turn up in Device Manager?
    Traktor Scratch Pro 2/Serato SL1/Ecler NUO 3.0/VCI 100 SE/2 x Technics 1210 Mk2/Sennheiser HD25 II/Novation Dicers

  4. #4

    Default

    yes, under "sound, video and game controllers" I can see 2 times

    "TYPHOON DJ-CONTROLLER"

  5. #5
    Tech Guru Sherlock Ohms's Avatar
    Join Date
    Jun 2009
    Location
    Bristol, UK
    Posts
    1,596

    Default

    If you right click and check properties, does it show any error messages?
    Traktor Scratch Pro 2/Serato SL1/Ecler NUO 3.0/VCI 100 SE/2 x Technics 1210 Mk2/Sennheiser HD25 II/Novation Dicers

  6. #6

    Default

    Nope "This device is working properly."

  7. #7
    Tech Guru Sherlock Ohms's Avatar
    Join Date
    Jun 2009
    Location
    Bristol, UK
    Posts
    1,596

    Default

    you tried uninstalling and reinstalling the drivers from the device manager window?
    Traktor Scratch Pro 2/Serato SL1/Ecler NUO 3.0/VCI 100 SE/2 x Technics 1210 Mk2/Sennheiser HD25 II/Novation Dicers

  8. #8

    Default

    I tried uninstalling it from the Asiofortyphoon folder in program files and reinstalling but not from device manager. I will try right away, thanks

  9. #9

    Default

    Right clicked and uninstalled both from device manager, disconnected device, repluged it and they both reappeared right away

    Opened traktor and still it shows "Asio for typhoon driver (Not connected) and at the bottom "Please connect and select an audio device"

  10. #10
    Tech Guru Sherlock Ohms's Avatar
    Join Date
    Jun 2009
    Location
    Bristol, UK
    Posts
    1,596

    Default

    (I don't own one of these so, this is all educated guesswork btw ...)

    Are you loading traktor with the Typhoon plugged in? - I know my system used to get moody with old BCD3000 if it wasn't plugged in first.

    With the Typhoon plugged in, is it possible to just play a track from winamp/itunes? i.e. just using it as a soundcard for another program?
    Traktor Scratch Pro 2/Serato SL1/Ecler NUO 3.0/VCI 100 SE/2 x Technics 1210 Mk2/Sennheiser HD25 II/Novation Dicers

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •