DDM4000/TSP2 Midi Problem
Results 1 to 7 of 7
  1. #1
    Tech Guru BFLY's Avatar
    Join Date
    Sep 2009
    Posts
    583

    Default DDM4000/TSP2 Midi Problem

    Hi Guys hope someone can help:

    Im using TSP 2 with and Audio 8 card, I have used Midi cables to link up a DDM4000 mixer, the problem is even after i have gone into the DDM midi settings, Traktor just isn't receiving any midi (the blue light is not lighting up!)

    Im using channel 1 on the mixer

    Could anyone please help?

    Thanks

  2. #2
    Tech Guru BFLY's Avatar
    Join Date
    Sep 2009
    Posts
    583

    Default

    The Midi in light is now turning on when i move anything on the mixer but traktor is still not getting any signals?

  3. #3
    DJTT Infectious Moderator photojojo's Avatar
    Join Date
    Apr 2010
    Location
    Sherman, TX
    Posts
    13,939

    Default

    Have you loaded a mapping for the mixer and set the in/out ports correctly? I always get confused with that mixer because the way it works is a little different.
    Chris Jennings FHP

    Podcast - Soundcloud - Mixcloud - Beatport Charts - x

  4. #4
    Tech Guru BFLY's Avatar
    Join Date
    Sep 2009
    Posts
    583

    Default

    will try that now, have downloaded midi monitor and its not picking up any signals

  5. #5
    Tech Guru BFLY's Avatar
    Join Date
    Sep 2009
    Posts
    583

    Default

    I have tried impoting a simple tsi from the traktor bible website, still no joy, could you explain about setting the in/out ports please?

  6. #6
    Tech Mentor Lineypirate's Avatar
    Join Date
    Dec 2010
    Location
    Essex/Hampshire, UK
    Posts
    189

    Default

    A few pointers.....

    1. Are your MIDI connectors correctly routed? The MIDI IN connector should be connected to the MIDI OUT on the mixer and the MIDI OUT connector should be connected to the MIDI IN on your mixer.

    2. Make sure you have a mapping loaded in the "Controller Manager" in Traktor.

    To get you started,

    * At the bottom of the screen click "Setup Wizard".

    * Connect your interface's USB to your computer, then click "Next".

    * On the drop down menu, select "Yes", then "Next".

    * On the top menu, select "Behringer" , on the bottom menu, select "DDM4000". Click "Next".

    * Complete the rest of the Setup Menu to your desired taste.

    3. Make sure your DDM4000 is set to the correct MIDI channel.

    * On the Controller Manager in Traktor, under the "Device" drop down, select the mapping for your DDM4000.

    * Under the MIDI in and out ports, make sure it is selected to "All Ports" or (more likely if you are using multiple MIDI controllers), USB-MIDI, or whatever your DDM4000 is connected to.

    * Under the "Mapped To" heading note which Channel Traktor expects to receive MIDI from.

    * On your DDM4000, hold down the menu encoder until the setup menu's appear. Using the menu encoder scroll down the list to "MIDI Settings".

    * In this menu, make sure your DDM is outputting on the correct channel, use the encoder to change this.

    * Last but not least, be sure to click the option "DUMP TO MIDI" in the DDM4000 MIDI menu. This will force the mixer to tell Traktor the current position and status of all MIDI controls / outputs on the mixer. This option is also useful for "bumping" your mixer into responding if it stops communicating with Traktor.

    Hope this helps. I've had this mixer for a couple of years now and I can't say enough good things about it, especially where it's customisation and MIDI capabilities are concerned!
    TSP 2.6.1 | 2 x CDJ 2000 Nexus | 2 x Technics 1210 MK5 | Denon DNX-1600 | Behringer DDM4000 w/Infinium X1 | MBP | A&H Xone K2 | Akai APC 40 & MPK 25 | Novation Launchpad | Pioneer HDJ 2000 & 500 | Audio 8 DJ | Ableton Live 9

    http://www.mixcloud.com/lineypirate/http://www.soundcloud.com/lineypirate/

  7. #7
    Tech Guru BFLY's Avatar
    Join Date
    Sep 2009
    Posts
    583

    Default

    Thanks for your help, I downloaded a new driver for the audio 8 and all seems to be working!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •