Latest update of Traktor Keylock issues
Results 1 to 10 of 10
  1. #1
    Tech Mentor NathanWard's Avatar
    Join Date
    Jul 2011
    Location
    Auckland, New Zealand
    Posts
    291

    Default Latest update of Traktor Keylock issues

    Is anyone else having issues with key lock since the 2.1.1 update? With keylock on and the pitch fader moved anymore than 1% I'm getting missing transients and occasional skipping sounds. This didn't happen before the update, and it only appeared around 2 weeks ago and has been getting worse.

    It only happens with Keylock on, and it's pretty annoying.
    BCF 2000
    Traktor Pro 2
    Kontrol X1


  2. #2
    Tech Mentor
    Join Date
    Nov 2011
    Posts
    179

    Default

    Hi, I used to keep my key-lock off but I had been hearing a lot of good stuff about TP2 key lock so I was playing with it the other day... And it was horrible. I was doubting everyone's ears that were saying key-lock is fine... But then, when I tested quite a few tracks yesterday, I couldn't reproduce the awful sound any more. It's suddenly "good enough" for me.

    I agree there might be an issue with the current version's key-lock, but I couldn't nail it. Got to be able to reproduce it before I email tech support.

  3. #3
    Tech Mentor Paka Ono's Avatar
    Join Date
    Jan 2011
    Location
    The middle of nowhere
    Posts
    495

    Default

    Disable multi core support? I found that it caused sound problems for me.

    It's a preference on one of the screens. I can't recall which one exactly.

  4. #4
    DJTT Moderator Dude Jester's Avatar
    Join Date
    Feb 2009
    Location
    New Zealand
    Posts
    12,333

    Default

    go back to 2.0.3 ... seriously
    Acer E5 i7 2TB 16GB ~ 512GB SSD ~ WIN 10 ~ TSP 2.11 ~ AUDIO 6 ~ X1 ~ DN-X1600 ~ X1 ~ SPECTRA ~ TWISTER ~ ATH-PRO500 MK2 ~ AT2020 MIC

    "This aggression will not stand, man."

  5. #5
    Tech Guru SirReal's Avatar
    Join Date
    May 2010
    Location
    San Fran Bay Area
    Posts
    2,204

    Default

    Nobody's mentioned specs. I've had no problem with keylock up to + or - 5% pitch fader and aliasing of audio. Anything beyond that and I really start to hear artifacts in the tracks. MBP 2.8 GHZ Intel core duo w/ 4GB Ram
    "Walking the fine line between Stupidity and Genious" My Soundcloud ---- My Mixcloud
    MBP Retina 2015--TSP 2.10--2xDNSC5000--2xDNSC2900--2xDNSC2000--NI F1--Denon DN-X1700--HDJ2000--Stanton STR8-80--QSC K12's--Crown Amplifier--Urei Monitors

  6. #6
    Tech Mentor NathanWard's Avatar
    Join Date
    Jul 2011
    Location
    Auckland, New Zealand
    Posts
    291

    Default

    Okay, I tried it with Multi core off and on, I found it better with it off, but it was still happening. Load meter hovers between 30-40%, less if Multi core support is off. I'm using a Traktor Audio 2, 44100 hz, 256 sample rate and have 9.7 ms.

    Computer specs: 2.7ghz Dual core, 2GB RAM, Windows 7 Home Premium.

    I might just go back to 2.0.3 for now, because I'm playing at a party on friday and don't want any problems.
    BCF 2000
    Traktor Pro 2
    Kontrol X1


  7. #7
    Tech Convert
    Join Date
    Apr 2011
    Posts
    13

    Default

    I had weird problems with the new sample deck keylock, (wrong pitch, glitchy transients, etc.) but i cant say i've had any problem with the track deck ones.

  8. #8
    Tech Mentor
    Join Date
    Jan 2011
    Location
    hampshire, UK
    Posts
    233

    Default

    sorry to jump in on this topic with a question.. I just got traktor scratch duo and came updated to 2.1.1. How would I get back to 2.0.3??
    Macbook Pro 2011 :: Xone 22 :: Technics 1200 :: Denon DNS3700 :: 2x Midifighter ::Akia MPD24 :: Kaoss Pad 2 :: Audio 6 :: KRK Rockit 5 Darkstar :: Roland Sh-101 :: Traktor Scratch Duo :: Ableton live 8


  9. #9
    Tech Guru
    Join Date
    Jan 2011
    Location
    Louisville, KY
    Posts
    701

    Default

    Quote Originally Posted by Jester.NZ View Post
    go back to 2.0.3 ... seriously
    this.

    I have been trying to get off 2.0.3 for quite a while but 2.1.X just doesn't work very well. Issues ranging from the keylock problem you mentioned to adjusting the phase with the jog is seriously laggy now with 2.1.X.

    PS: turning off multi core corrected the pops hisses and cracks but the other issues remain.

  10. #10
    Tech Guru mostapha's Avatar
    Join Date
    May 2010
    Location
    Atlanta
    Posts
    4,748

    Default

    Quote Originally Posted by Jester.NZ View Post
    go back to 2.0.3 ... seriously
    I dont think I'm having problems.

    What did 2.1.1 add other than a lot of bugs that appear not to show up with the way I work?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •