DJM-900 not compatible with Mac OS10.6
Results 1 to 3 of 3
  1. #1
    Tech Student
    Join Date
    Dec 2011
    Posts
    2

    Default DJM-900 not compatible with Mac OS10.6

    So I'm trying to get the facts on the street about the DJM-900 Nexus. Pioneer has not address this issue yet nor have they made any attempts to let consumers know so please help me and re-post this in other forms if you feel the need to. The rest of this post is what I posted on pioneers form which can be found:

    http://forums.pioneerdj.com/entries/...-not-supported

    Back in Auguest there was a post made about this topic and was eventually locked.

    EDIT: found the post http://forums.pioneerdj.com/entries/...driver-incompa...



    To sum up the issue, I just downloaded and installed the newest driver for my DJM-900 and when I attempt to use it as my audio interface with Traktor and my timecodes, Traktor is reporting that the "input channel: not supported." In the post that was closed, it was discovered that the DJM-900 is not compatible with OS10.6 and the standard response when questioned about this issue was (and I am paraphrasing) 'The engineers are working on a solution currently'.

    Was this issue addressed in the newest update? If not why and when can I expect a working driver? At this point I would appreciate some very frank and real answers. Is pioneer offering something to compensate me for my inconvenience? I am not satisfied with this issue and I am even less happy about the difficulty in getting a response. Just to make my point, when I went to the store to buy my mixer there wasn't an option to pay later, and even if there was it wouldn't let me be vague about when I would fully repay my debt. Pioneer has my money currently, but I feel I have yet to fully receive the services/goods I paid for.

    At the very least I think pioneer should make an official statement saying that they currently do not support OS 10.6 and that they are either planning to or not future support it. It's not fair to consumers to not make vital information like system compatibility easily accessible.



  2. #2
    Tech Guru Conall's Avatar
    Join Date
    Apr 2010
    Location
    Scotland
    Posts
    607

    Default

    From my experience pioneer customer service is even worse than NI. personally i dont understand why anyone would want to buy a nexus anyway when you can get a db4 for pretty much the same price

  3. #3
    Tech Student
    Join Date
    Dec 2011
    Posts
    2

    Default

    It's good to know I'm not the only one that has had trouble with both those companies. Honestly it is starting to seem like cooperate policy to blow off the customer. I have always liked allen and heath so I'll definitely consider the db4 now. I was originally excited about the 900 because I already had an 800 and was using my traktor interface, I was hoping to reduce the amount of equipment I had while also keeping the feel of a mixing i loved, sadly I feel the 900 was a step down. How is the effects unit on the allen and heath?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •