Kontrol X1 Encoder No Longer Clicking
Results 1 to 3 of 3
  1. #1
    Tech Convert
    Join Date
    Oct 2010
    Posts
    13

    Default Kontrol X1 Encoder No Longer Clicking

    I've had my X1 for just about a year now, and I use it as pretty much my sole controller unless I borrow one from a friend of mine. The whole thing still works excellently except for one of the encoders, which has gotten progressively more difficult to click.

    The specific encoder is the one mapped for track browsing and loading functionality, and I feel like it may just be worn down from all the use, or I probably have crushed it a little too hard throughout the year.

    I was wondering if anyone else was having this problem, I figure it's not very likely that I'm the only one, and I was also wondering if anyone had any solutions.

    I could just map around it, but I'm really comfortable with the default mapping as is (I'd be willing to change but only as a last resort). What I'm more interest in would be replacing the encoder itself. I figure this has got to be possible, but I'm not 100% sure, so again if anyone has any experience modding the X1 or has more information to share on this problem any replies would be greatly appreciated

  2. #2
    DJTT Infectious Moderator photojojo's Avatar
    Join Date
    Apr 2010
    Location
    Sherman, TX
    Posts
    13,939

    Default

    I would contact NI and see if they'll send you a replacement. It would probably mean sending yours off first so they can check it though.
    Chris Jennings FHP

    Podcast - Soundcloud - Mixcloud - Beatport Charts - x

  3. #3
    Tech Convert
    Join Date
    Oct 2010
    Posts
    13

    Default

    For reference, I fixed it. All I did was slip off the the knob and put it back on, works like it was brand new again. Guess I was worried over nothing

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •