Getting APC40 to ignore Traktor?
Results 1 to 5 of 5
  1. #1
    Tech Mentor Lineypirate's Avatar
    Join Date
    Dec 2010
    Location
    Essex/Hampshire, UK
    Posts
    189

    Default Getting APC40 to ignore Traktor?

    Hey guys, I'm having a lot of fun with my new APC40 in both Ableton and Traktor (props to C-Lab for his awesome TPro 2 mapping) but have become stuck when it comes to implementing the APC40 with my wider setup.

    I normally play with Traktor via DVS with my Launchpad controlling FX (again, props to JWILL for his Launchpad mapping) and would like to use Ableton with my APC at the same time to play some loops / synths / samples.

    My problem comes when I load up Traktor, my APC reverts to "Dumb Mode" and will not control Ableton at all. I can get my Launchpad to ignore the fact that Ableton is open and only control Traktor, but can't get my APC to ignore Traktor and just control Ableton!

    I've tried deleting the APC from Traktor's Controller Manager and setting all the ports correctly for my remaining MIDI equipment but my problem remains!

    Any idea's or suggestions?

    Cheers in advance!
    TSP 2.6.1 | 2 x CDJ 2000 Nexus | 2 x Technics 1210 MK5 | Denon DNX-1600 | Behringer DDM4000 w/Infinium X1 | MBP | A&H Xone K2 | Akai APC 40 & MPK 25 | Novation Launchpad | Pioneer HDJ 2000 & 500 | Audio 8 DJ | Ableton Live 9

    http://www.mixcloud.com/lineypirate/http://www.soundcloud.com/lineypirate/

  2. #2
    Tech Guru Steve Zorilow's Avatar
    Join Date
    Apr 2010
    Location
    Montréal, Québec, Canada
    Posts
    1,236

    Default

    the only way I know to share a controller between multiple applications is to use a virtual MIDI cable. For PC you need MIDI-OX and MIDI yoke.
    Steve Zorilow: Facebook - Soundcloud - Mixcloud - Twitter

  3. #3
    Tech Mentor Lineypirate's Avatar
    Join Date
    Dec 2010
    Location
    Essex/Hampshire, UK
    Posts
    189

    Default

    I'm on a Mac. I presume the same effect can be achieved via OSX's own Virtual MIDI capabilities? And I'm not so much trying to share a controller, rather than get my APC to ignore the fact that Traktor is open completely!

    Cheers for your help!
    Last edited by Lineypirate; 12-31-2011 at 07:36 AM.
    TSP 2.6.1 | 2 x CDJ 2000 Nexus | 2 x Technics 1210 MK5 | Denon DNX-1600 | Behringer DDM4000 w/Infinium X1 | MBP | A&H Xone K2 | Akai APC 40 & MPK 25 | Novation Launchpad | Pioneer HDJ 2000 & 500 | Audio 8 DJ | Ableton Live 9

    http://www.mixcloud.com/lineypirate/http://www.soundcloud.com/lineypirate/

  4. #4
    Tech Guru Steve Zorilow's Avatar
    Join Date
    Apr 2010
    Location
    Montréal, Québec, Canada
    Posts
    1,236

    Default

    Something's strange with your Traktor MIDI mapping then. I would check ALL mapping and double check, or even reassign each MIDI IN & MIDI out port AND make sure there's no ALL PORT assigned for IN or OUT.
    Steve Zorilow: Facebook - Soundcloud - Mixcloud - Twitter

  5. #5
    Tech Mentor Lineypirate's Avatar
    Join Date
    Dec 2010
    Location
    Essex/Hampshire, UK
    Posts
    189

    Default

    Cheers for the help. I went through all my mappings again and reassigned everything and deleted any mappings that weren't being used. And happy to report that everything works!

    Turns out I had to remove or reassign anything that was looking for input under "Traktor Virtual Input/Output" or "All Ports".

    Thanks again!
    TSP 2.6.1 | 2 x CDJ 2000 Nexus | 2 x Technics 1210 MK5 | Denon DNX-1600 | Behringer DDM4000 w/Infinium X1 | MBP | A&H Xone K2 | Akai APC 40 & MPK 25 | Novation Launchpad | Pioneer HDJ 2000 & 500 | Audio 8 DJ | Ableton Live 9

    http://www.mixcloud.com/lineypirate/http://www.soundcloud.com/lineypirate/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •