X1 soft takeover not working
Results 1 to 7 of 7
  1. #1
    Tech Guru MaxOne's Avatar
    Join Date
    Jan 2009
    Location
    London, UK
    Posts
    2,917

    Default X1 soft takeover not working

    Word.

    My VCI usb port is buggered, i got a replacement but i got a gig coming up so just thought i'd map my x1 for 2 deck control in a way that makes sense to me.

    Anyway, so i'm trying to use knob 3 to control filter in normal state and gain in shift state.

    I've got soft takeover assigned to both but it doesn't work.

    As soon as i move the knob it jumps to position, rendering it useless.

    Anyone encounter this or know what i'm doing wrong?

    Ta very muchly
    CLUB OF JACKS - RELEASES >>TRAXSOURCE
    Club of Jacks are a London based House & Garage production / DJ duo with releases on a number of underground labels including Plastik People Recordings, Blockhead Recordings, Hi Energy!, Pocket Jacks Trax, Soul Revolution Records and their own Club of Jacks imprint.

  2. #2
    Tech Mentor Audeo's Avatar
    Join Date
    Oct 2010
    Location
    Enschede, The Netherlands
    Posts
    415

    Default

    It's a known bug but what really bothers me is that NI knows it and does nothing about.
    Midi Fighter|Kontrol X1|A4DJ|HDJ2000|MBP 13" 2,53Ghz 60GB SSD/500GB HDD

  3. #3
    DJTT Moderator Dude Jester's Avatar
    Join Date
    Feb 2009
    Location
    New Zealand
    Posts
    12,311

    Default

    Yeas it some ongoing bug with the filters its been pissing me off since i picked up an x1.
    Acer E5 i7 2TB 16GB ~ 512GB SSD ~ WIN 10 ~ TSP 2.11 ~ AUDIO 6 ~ X1 ~ DN-X1600 ~ X1 ~ SPECTRA ~ TWISTER ~ ATH-PRO500 MK2 ~ AT2020

    "This aggression will not stand, man."

  4. #4
    Tech Guru MaxOne's Avatar
    Join Date
    Jan 2009
    Location
    London, UK
    Posts
    2,917

    Default

    Liberties they haven't sorted that out
    CLUB OF JACKS - RELEASES >>TRAXSOURCE
    Club of Jacks are a London based House & Garage production / DJ duo with releases on a number of underground labels including Plastik People Recordings, Blockhead Recordings, Hi Energy!, Pocket Jacks Trax, Soul Revolution Records and their own Club of Jacks imprint.

  5. #5
    Tech Wizard
    Join Date
    Aug 2014
    Location
    Leeuwarden, Holland
    Posts
    40

    Default

    Any known fixes for this so far?

    I would really like to get it working....
    Love it when it all comes together.

  6. #6
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    7,305

    Default

    Nope it's a veteran bug. Only recently affected my F1 too.

  7. #7
    Tech Wizard
    Join Date
    Aug 2014
    Location
    Leeuwarden, Holland
    Posts
    40

    Default

    Oh well then i'll just not map any double functions in the rotaries for now...

    I've had the same issue with my F1's aswel, got it fixed after fully deleting traktor and all saved settings etc. then reimport the .tsi for your custom mapping into a fresh Traktor. Didn't work with the X1's tho...

    I've got a friend who might try to fix the x1 driver soon, i'll keep ya'll up to date when he starts on it and of course when he finishes it!
    Love it when it all comes together.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •