Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Banned
    Join Date
    Jun 2012
    Posts
    219

    Default traktor 2.5 and kontrol S4??

    Ughh okay, I'm sorry guys. Usually I'd never do this, I know this doesn't go here, but I have a big gig tomorrow and I have to get this fixed by then. Really need your help guys. The S4 forums failed. I've tried EVERYWHERE else and got nothing, so please... any help?

    Upgraded to 2.5.... and now traktor won't even recognize my s4 as a controller. Doesn't show up in the controller manager, doesn't even show up in the set up wizard (even though 3 controllers I don't have show up)... It shows up as an audio card just fine, but will not work as a controller. I have the newest S4 driver available for PC (3.0.3)... but nothing works.... any ideas? How the hell can NI fail this hard?

  2. #2
    Banned
    Join Date
    Jun 2012
    Posts
    219

    Default

    Also,

    computer specs

    running windows 7, with and without the usb audio card hotfix.

  3. #3

    Default

    Could it be a simple as the button at the back of your S4 has been switched off? Easily done as you think its on due to the light up as the UBS is plugged in?

  4. #4
    Tech Guru
    Join Date
    Dec 2011
    Location
    UK
    Posts
    615

    Default

    Quote Originally Posted by Saurus View Post
    Ughh okay, I'm sorry guys. Usually I'd never do this, I know this doesn't go here, but I have a big gig tomorrow and I have to get this fixed by then. Really need your help guys. The S4 forums failed. I've tried EVERYWHERE else and got nothing, so please... any help?

    Upgraded to 2.5.... and now traktor won't even recognize my s4 as a controller. Doesn't show up in the controller manager, doesn't even show up in the set up wizard (even though 3 controllers I don't have show up)... It shows up as an audio card just fine, but will not work as a controller. I have the newest S4 driver available for PC (3.0.3)... but nothing works.... any ideas? How the hell can NI fail this hard?
    Sorry to hear of your prob. Did you check the S4 was switched off/disconnected from the computer before upgrading to 2.5? Windows will kindly try to apply incorrect drivers to the S4 if Traktor has not been installed/upgraded before connecting, this could be the problem. I think the remedy(?) is to uninstall the NI software and repeat the process without connecting the S4. Hope you get it sorted.

    Cheers

  5. #5
    Banned
    Join Date
    Jun 2012
    Posts
    219

    Default

    Nah.... tried that thanks though... other ideas?

  6. #6
    Tech Convert
    Join Date
    Jul 2012
    Posts
    13

    Default

    Windows? The solution to all windows problems is a reboot. Or buy a mac >_>. Maybe start fresh? uninstall it reinstall it. check for updates in the service center? is it a new s4? have you registered it in the service center?

    I'm just throwing out random ideas to hopefully spark new ones >_>

  7. #7
    Banned
    Join Date
    Jun 2012
    Posts
    219

    Default

    Tried all of that. It's not windows' fault, it's that NI doesn't know how to program, and are dicks.... The new S4 mac driver has been out for six months, and the previous one worked just fine... still no working windows driver though.

  8. #8
    Tech Convert
    Join Date
    Mar 2012
    Location
    Ireland
    Posts
    13

    Default

    Sorry to be this guy but reinstall? http://www.native-instruments.com/kn...rs+in+Mac+OS+X
    Traktor Kontrol S4 | KRK Rokit RP5 Monitor Speakers | Traktor Scratch Pro 2 | Pioneer HDJ2000 | Macbook Pro 15-inch Mid-2010

  9. #9
    DJTT Scribe Mod smiTTTen's Avatar
    Join Date
    Jan 2011
    Location
    Then: UK. Now: US.
    Posts
    1,939

    Default

    I just upgraded and the same thing has happened. Traktor appears to recognize the S4's audio interface but not the controller side. I plan on doing the re-install later though my experience has shown me that NI still leave a plethora of stuff on the system after the uninstall.
    Beats By Dre is like audio flu for your balls.

  10. #10
    Banned
    Join Date
    Jun 2012
    Posts
    219

    Default

    Yeah... I tried to reinstall like five or six times... no luck.....

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •