Novation Remote Zero - change led status
Results 1 to 8 of 8
  1. #1
    Tech Wizard psylozen's Avatar
    Join Date
    May 2009
    Location
    Dartmouth, NS, CANADA
    Posts
    77

    Default Novation Remote Zero - change led status

    Hi folks,

    I'm trying to setup the record button on my zero to work as a toggle for FX. I currently have it setup in Traktor (1.1.2) to turn a modifier on and off.

    That part of it all works fine.

    Problem I'm having is trying to turn the led above the record button on when I'm in fx mode, and turn it off when I'm not in fx mode.

    The traktor nor zero manual is very helpful, neither are the NI forums. And posts here seem to be focused on the vci-100...

    Can anybody point me in the right direction?


    Thanks!

    m.
    mixes at: http://soundcloud.com/psylozen

    "Life isn't about how to survive the storm, but learning how to dance in the rain."

  2. #2
    Tech Mentor
    Join Date
    May 2009
    Location
    Maryland
    Posts
    322

    Default

    not a problem. you have to set up an identical midi mapping along with the ones you have now, but set the controller type to output - LED.
    I'm not good at things, but I like to pretend I am.
    :Project-Segfault:

  3. #3
    Dr. Bento BentoSan's Avatar
    Join Date
    Mar 2008
    Location
    Perth, Australia
    Posts
    6,356

    Default

    http://www.djtechtools.com/forum/showthread.php?t=1506 - *** ! READ ME FIRST ! *** Posting Instructions

    Read the stickies before posting, moved to the general forum.

  4. #4
    Tech Wizard psylozen's Avatar
    Join Date
    May 2009
    Location
    Dartmouth, NS, CANADA
    Posts
    77

    Default Oops

    Sorry for posting in the wrong forum...

    I've tried setting it to Output - LED, but nothing lights up.

    Any other suggestions?

    tks,

    m.
    mixes at: http://soundcloud.com/psylozen

    "Life isn't about how to survive the storm, but learning how to dance in the rain."

  5. #5
    Dr. Bento BentoSan's Avatar
    Join Date
    Mar 2008
    Location
    Perth, Australia
    Posts
    6,356

    Default

    Are your LED's working otherwise on your device and this is just a midi mapping issue ?

    If yes then put the midi assignments that your trying to use here and we can tell you where your going wrong.

    If no then theres a problem with your midi pipe going from Traktor to your controller, make sure your have the controller selected as a midi output in Traktor.

  6. #6
    Tech Wizard psylozen's Avatar
    Join Date
    May 2009
    Location
    Dartmouth, NS, CANADA
    Posts
    77

    Default The Details:

    Quote Originally Posted by BentoSan View Post
    Are your LED's working otherwise on your device and this is just a midi mapping issue ?
    The record button is the only midi-mappable button with an LED associated with it, but I can't say for sure that I've ever seen it light up. All the other non-midi-mappable buttons' leds work as expected.

    Quote Originally Posted by BentoSan View Post
    If yes then put the midi assignments that your trying to use here and we can tell you where your going wrong.
    I've got the controls on the Zero configured as follows:

    record/FX on button
    Type: Note On/Off
    Midi port group: usb port 1 and midi port 1 enabled. usb port 2 and 3, and midi port 2 disabled
    Midi channel: 5
    Note number: 4 (e-2)
    Velocity: 127
    Button type: toggle

    There is *nothing* in the settings for that button about an LED. The other options for Type are: Disabled, CC, NRPN, PRN, SysEx, Program Change, MMC, and Note on/off.


    Traktor config looks like this:
    1st assignment:
    Note E-1 (ch5)??

    (Midi-ox tells me that the Zero is actually sending E-1, so the template editor for the zero is buggy. Aka, doesn't have anythign to do w/ my problem.)

    Lock OMNI is off
    CH 5 is selected
    Interaction: Hold
    Assignment: Global
    Type: Button
    Modifier conditions are not set
    Set to value: 1

    2nd assignment:
    Note E-1 (ch5)
    Lock OMNI is off
    CH 5 is selected
    Interaction: Output
    Type of Controller: LED
    Modifier conditions are not set

    LED Options (Original)
    Controller-Range
    min:0 max:7 invert is not checked
    midi-range
    min:0 max:127 blend is checked


    LED Options (current, but I've played w/ these a lot)
    Controller-Range
    min:0 max:1 invert is checked
    midi-range
    min:0 max:1 blend is not checked

    The modifier works for sure. I can turn the FX functionality on and off.

    It's just not turning the LED on...

    ..of course, I'm not 100% sure I'm doing it right...

    ...or that it even can be turned on/off by midi..

    ....or works...

    Quote Originally Posted by BentoSan View Post
    If no then theres a problem with your midi pipe going from Traktor to your controller, make sure your have the controller selected as a midi output in Traktor.
    In Traktor I have the following options under Midi Setup for both in and out

    Remote Zero SL: Port 1 (emulated)
    Remote Zero SL: Port 2 (emulated)
    Remote Zero SL: Port 1 (emulated)
    Audio8 DJ In/Out (emulated)

    I usually only have Port 1 turned on since everything on the zero is limited to port 1, but I've turned them all on (except the audio8) for debugging. It's made no difference.


    What's my next step?

    Thanks!

    m.
    mixes at: http://soundcloud.com/psylozen

    "Life isn't about how to survive the storm, but learning how to dance in the rain."

  7. #7
    Tech Wizard psylozen's Avatar
    Join Date
    May 2009
    Location
    Dartmouth, NS, CANADA
    Posts
    77

    Default bump?

    Please don't make me call tech support (:

    Nothing I can do to figure out how to turn the damn light on? Perhaps I could flood the controller w/ midi messages until I find the right one?

    I'm wide open to suggestions...


    tks

    m.
    mixes at: http://soundcloud.com/psylozen

    "Life isn't about how to survive the storm, but learning how to dance in the rain."

  8. #8
    Retired DJTT Moderator DvlsAdvct's Avatar
    Join Date
    Mar 2008
    Location
    New Jersey/NYC
    Posts
    4,826

    Default

    Turn off blend for LEDs. It should never be on.

    Try changing the LED output to what the note is supposed to be in the editor?
    It's the FAQ. Read it.

    My Mixes, Mashups and Rants

    Divided we stand
    United we fall

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •