Z2 Traktor Button & the Level Meters
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Tech Mentor
    Join Date
    Jul 2010
    Posts
    175

    Default Z2 Traktor Button & the Level Meters

    When running audio from Traktor with the "Z2 Traktor Button" OFF the level meters for A &/or B dont display. The Master Leds display but not A & B.

    I understand the Traktor button toggles audio handling between the Z2 and Traktor for Gain, EQ and Volume.

    The manual says we can switch between the two on the fly and as far as the audio goes and the master Level Meters I can do that. However, I want the A & B level meters to display regardless of which mode I am in. At present they only display when the "Z2 Traktor button" is on.

    Yes, I could leave the "Z2 Traktor button" on but I bought an external mixer so I could mix externally. So, why dont the level meters work when I send audio from Traktor to the Z2 mixer?

    Maybe there is some setting I am missing, but I cant find anything in the manual.

    NB: This is only when running audio from Traktor. Audio in via the Line / Phono works fine.

  2. #2
    Tech Guru
    Join Date
    Feb 2010
    Location
    Desert Hot Springs, CA
    Posts
    763

    Default

    External mode is only for external devices (cdj/turntable/ipod) only.
    The Z2 only has 2 sets of physical outs. One is the Headphone Cue, the other is the Master Out.

    In short, you can't do it. Traktor mode for Traktor decks.
    Hardware: Akai Max49, Maschine, Equator D5 monitors, Saffire Pro 14
    Software: Logic, Maschine
    My Neighbors Listen to House Music.. Because They Have To.

  3. #3
    Tech Mentor
    Join Date
    Jul 2010
    Posts
    175

    Default

    It's still got 4 stereo of inputs.... why dont they allow me to route the audio to each of the inputs like a normal soundcard mixer?

    I have an NI mixer that only works as a midi controller when using NI Traktor. Seems to defeat the purpose ... no?
    Last edited by rishi; 12-03-2012 at 07:40 PM. Reason: 4 stereo IN's not 2

  4. #4
    Tech Guru
    Join Date
    Jan 2011
    Location
    Louisville, KY
    Posts
    701

    Default

    Call NI support and voice your displeasure. Also mention that its lame to grey out the mater out volume level in Traktor when the Z2 is plugged in.

  5. #5

    Default

    map the vu meters for internal to those leds on the controller(Z2)...similar to what we have to do for the vci-400 EGE on the outer channels C&D

  6. #6
    Tech Mentor
    Join Date
    Jul 2010
    Posts
    175

    Default

    Other Traktor Certified Mixers process audio from Traktor. The Z2 has 4 stereo IN's. So, why doesnt a Traktor Mixer get to process Traktor audio?

    I actually expect that the mixer could function this way but is limited from doing so because Traktor Preferences - Output Routing - Mixing Mode is set to INTERNAL and EXTERNAL is greyed out (unavailable).

    Why cant I change it to External mixing and route Traktor audio to the Z2 stereo INPUTS?

    There may be a valid reason for this I dont know???

  7. #7
    Tech Guru papo's Avatar
    Join Date
    Feb 2011
    Location
    Miami, Fl
    Posts
    555

    Default

    Quote Originally Posted by rishi View Post
    When running audio from Traktor with the "Z2 Traktor Button" OFF the level meters for A &/or B dont display. The Master Leds display but not A & B.

    I understand the Traktor button toggles audio handling between the Z2 and Traktor for Gain, EQ and Volume.

    The manual says we can switch between the two on the fly and as far as the audio goes and the master Level Meters I can do that. However, I want the A & B level meters to display regardless of which mode I am in. At present they only display when the "Z2 Traktor button" is on.

    Yes, I could leave the "Z2 Traktor button" on but I bought an external mixer so I could mix externally. So, why dont the level meters work when I send audio from Traktor to the Z2 mixer?

    Maybe there is some setting I am missing, but I cant find anything in the manual.

    NB: This is only when running audio from Traktor. Audio in via the Line / Phono works fine.
    Check out this video. He is using the right deck on external mode and is getting LED feedback. Is this what you are asking?


  8. #8
    Tech Mentor
    Join Date
    Jul 2010
    Posts
    175

    Default

    Thanks but not what I am after. I now understand that my level meters work per specifications.

    To explain.... With the input routing turned off in preferences, pressing the traktor buttons allowed audio from traktor when on or off. This made me think that I could process audio in Traktor or in the Z2. However, the Meters werent working when the Traktor buttons were off. So, I thought there was a problem. Soon as I setup input routing I could no longer play Traktor audio with the Traktor button off.

    So, now my question is why does the Z2 only allow INTERNAL mixing mode and not EXTERNAL mixing mode in Traktor Preferences.
    Other USB Soundcard mixers surely work this way. I wonder why the Z2 doesnt??

    As DJ Asand correctly points out Traktor mode is for Traktor and external is for external sources only.

  9. #9
    Tech Mentor
    Join Date
    Jul 2010
    Posts
    175

    Default

    Quote Originally Posted by rishi View Post
    So, now my question is why does the Z2 only allow INTERNAL mixing mode and not EXTERNAL mixing mode in Traktor Preferences.
    Other USB Soundcard mixers surely work this way. I wonder why the Z2 doesnt??
    I think the answer to this question is to allow for Post Fader FX. External Mixing with Post Fader FX would require setting up a Send/Return. Internally, it can be processed without extra physical routing. ????

  10. #10
    Tech Guru
    Join Date
    Feb 2010
    Location
    Desert Hot Springs, CA
    Posts
    763

    Default

    exactly.
    still sucks though. I wanted to use the external mixer capabilities with post fader fx.. like the DN-X1600
    Hardware: Akai Max49, Maschine, Equator D5 monitors, Saffire Pro 14
    Software: Logic, Maschine
    My Neighbors Listen to House Music.. Because They Have To.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •