Losing effects with X1/S4
Results 1 to 7 of 7
  1. #1

    Default Losing effects with X1/S4

    Hello,

    I have an S4, X1 and an F1 as my kit. Overkill? Naw! I love it....

    Problem is when I connect the X1, I loose the capability on my S4 to control FX bank 1 on Deck B, and I lose capability to control FX bank 2 on Deck A.

    Is there a fix to this? I would like to still be able to control effects banks 1 and 2 on deck a and b. I control deck c and d with the X1, so no big deal there.

    Thanks

    DJ Sandor

  2. #2
    Tech Wizard
    Join Date
    Jun 2012
    Location
    Rotterdam, the Netherlands
    Posts
    85

    Default

    Do you use a powered usb hub, because most computers can't deliver the power for 3 controllers.

  3. #3
    DJTT Administrator del Ritmo padi_04's Avatar
    Join Date
    Nov 2009
    Location
    Argentina
    Posts
    6,493

    Default

    Double check your FX units are assigned properly per deck, you can check that on the S4's mixer section, the X1's FX1-2 buttons (assuming you are using the native maps) or in Traktor's UI if the correct layout is selected.

  4. #4

    Default

    Hey guys, thanks for the reply

    No powered hub, my S4/F1/and X1 are all plugged into the PC. I am using the X1 to control FX 3 and 4. I am using the S4 to control FX 1 and 2.
    Using the Standard Traktor layout. I just cant assign FX unit 1 to deck B and vise versa (using S4), and I cannot assign FX unit 2 to Deck A using the S4 hardware. I can assign them in the software though.

    Any thoughts?

  5. #5

    Default

    Quote Originally Posted by luckee_d_1999 View Post
    Hey guys, thanks for the reply

    No powered hub, my S4/F1/and X1 are all plugged into the PC. I am using the X1 to control FX 3 and 4. I am using the S4 to control FX 1 and 2.
    Using the Standard Traktor layout. I just cant assign FX unit 1 to deck B and vise versa (using S4), and I cannot assign FX unit 2 to Deck A using the S4 hardware. I can assign them in the software though.

    Any thoughts?
    I get the same thing when running my X1 alongside my S4, not sure why it happens.
    2 x CDJ 850 | Kontrol S4 | A&H Xone XD-53's | A&H Xone K2 | Kontrol X1 | Kontrol F1 | DJM 900nxs

  6. #6

    Default

    Submitted a ticket into NI. I dont know how to map this and do not understand why the functionality is lost. I am at a loss here

  7. #7

    Default

    Quote Originally Posted by firebr4nd View Post
    I get the same thing when running my X1 alongside my S4, not sure why it happens.
    Any luck figuring it out??/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •