Ableton 9 64-bit version won't scan for 32-bit VSTs
Results 1 to 3 of 3
  1. #1
    Newbie
    Join Date
    Mar 2013
    Posts
    1

    Default Ableton 9 64-bit version won't scan for 32-bit VSTs

    Hi! First thread for me at DJTT.

    Well. Read the title.
    Is there an update for this?
    According to Ableton I need a 3rd party-plugin to use them, but WHY?

    https://www.ableton.com/en/articles/...t-jbridge-mac/

  2. #2
    DJTT Administrator del Ritmo padi_04's Avatar
    Join Date
    Nov 2009
    Location
    Argentina
    Posts
    6,493

    Default

    32bit plugins are not compatible with the 64bit version. It's stated on Ableton's website.

    Unless you are getting low memory errors from Live they recommend to use the 32bit version.

  3. #3
    DJTT #1 setup pimp 2012
    Join Date
    Feb 2012
    Location
    Boston, MA
    Posts
    259

    Default

    I am a software engineer, so I do understand 32-bit/64-bit differences.

    I too wouldn't mind knowing the limitations of providing the ability to pull in 32-bit plug-ins.

    I don't actually know the VST API standard. I would guess that they allow shared memory for plug-ins and the host application (Ableton)?

    This might be a product management decision on their side to not support this, for stability and compatibility reasons.

    EDIT: Ah, it looks like VST's are pulled in much like dynamically linked libraries. This is different from having them pop up as their own executable and then using some inter-process communication (IPC) to get the data back and forth to the host (like using pipes or some other construct). They could implement a bit bridge to do this, but eh, it's more stable and easier to request the plug-in vendors to port to 64-bit.
    Last edited by Ryan Ruel; 03-28-2013 at 10:07 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •