Help! Trying to fix my Stanton t.92
Results 1 to 4 of 4
  1. #1
    Tech Convert
    Join Date
    Mar 2013
    Posts
    14

    Default Help! Trying to fix my Stanton t.92

    Hey everyone!

    I just got a Stanton T.92 and for some reason it does not turn on. I got it from craigslist so return it is not an issue since the guy is not responding. I've read from other turntables when they don't turn on, usually means a blown fuse. I want to open it to check it out, but I can't find anywhere on the web on how to take it apart and to it back together. I see alot of clips on 1200s and TTXs, but none on the T.92.

    If anyone here has taken their t.92 apart or know how to check the fuses on it, please let me know!

    Thanks again!

  2. #2
    Tech Convert
    Join Date
    Mar 2013
    Posts
    14

    Default

    So I found out how to replace the fuse and it looks like it isn't blown. Does anyone happened to know anything else that may prevent it from turning on?

  3. #3
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    7,350

    Default

    I'd try different cable first and check power switch.

  4. #4
    Newbie
    Join Date
    Jun 2014
    Posts
    1

    Default T92

    Quote Originally Posted by dynamikeee View Post
    So I found out how to replace the fuse and it looks like it isn't blown. Does anyone happened to know anything else that may prevent it from turning on?
    Can you please educate me on how you found the fuse???
    My turntable has a fried fuse( my guess)
    I am not sure where to find it
    Please help!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •