Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2014

    Default Blue Led Technics 1200 mod, attempted, now 2 lights not working, plz help, thanks!

    Ok, I'm new here, I had ordered a blue led kit for my technics turntables...Included Pitch Fader led, Strobe Light led, and Target Light led...I followed instructions to a tee. I reassembled everything and now I have issues...The only thing that seems correct is the pitch fader light which is working...both the target light and the strobe is no longer working...attached is a pic of both...There is a resistor between where the red and orange wires meet as provided by the led light kit I purchased (is this resistor needed?) ...can someone please tell me what is going on with this...As I said, I followed the instructions to a tee and was very gentle with everything and my soldering...thank you! Please help
    Also a faint burning smell when everything is powered up...I didn't have platter on at first and then read where I needed this this smell just from that initial fire up of not having the platter on at first?? thanks

    Pics attached...Also have pic of the pop up light Im speaking of above but attachment was too large so can send to whomever can help me or attempt to...thank you!
    Attached Images Attached Images

  2. #2
    Join Date
    Sep 2015

    Default theres a lot of electronic calculation needed

    im doing it myself and have seen many tutorials, it depends mostly on the info of the led color, you need to know the mA (miliamps) too, colors have different voltage drop so find out what is your voltage on the led and how many miliamps it consumes. then you have so measure the volts the turntable is sending so you can calculate the resistor.
    try this page so you can calculate the resistor for the target lamp. or see this tutorial
    and see this tutorial for the strobe leds

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts