Results 1 to 3 of 3
  1. #1
    Tech Student
    Join Date
    Apr 2014
    Posts
    2

    Default LED's go out when others triggered

    Version - Traktor 2.6

    FYI, I was able to do this on a Launchpad and the LEDs work fine.

    While mapping my budget controller - Gemini CNTRL 7, When one LED is lit and I press a button that lights a different LED, it turns off the first LED. The controls themselves work fine, just the light goes out. The LEDs only have 1 on-state for this controller, they are either on or off no color changes or flashing by midi value.

    Example:
    map deckA play to midi out D3
    map deckB play to midi out D4
    press deckA play - D3 lights up (deck A plays)
    press deckB play - D4 lights up, but D3 goes out (both decks playing)
    press deckA play - D3 stays off, D4 goes out (deck B still playing)

    Here is the specific input and output mapping I am using:
    Add In - Play/Pause (Deck Common)
    Ch01.Note.D3
    type - button
    interaction mode - toggle
    assignment - Deck A

    Add Out - Play/Pause (Deck Common)
    Ch01.Note.D3
    type - LED
    interaction mode - Output
    assignment - Deck A
    Controller range - 0, 1
    Midi range - 0, 127

    Am I missing some logic here? At first I thought I might have been using an incorrect control (play/pause deck common), but if I add a light for master-deck it does the same thing.

    I realize the cntrl 7 isn't the greatest of devices, so I am not ruling out some order of operations that must be done specific to this controller.

    Full disclosure - the D3 and D4 notes above are incorrect and used as a trivialization, as the LED map does not match the button map on this controller (which sucks). It makes more visual sense in this example.

    Any assistance is appreciated.

  2. #2
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    5,137

    Default

    Note that the CNTRL line of controllers are not full MIDI. This is a VDJ controller and some of buttons are communicating to VDJ via HID protocol. Some buttons are also sharing the same MIDI note so perhaps that's why you're seeing that issue.

  3. #3
    Tech Student
    Join Date
    Apr 2014
    Posts
    2

    Default

    @Stewe

    Yes, I've found that to be problematic. I've heard a lot about them having HID communication as well, even though it is advertised as "MIDI". But I will keep my fingers crossed that somebody may have already figured part of this out.

    If I end up getting it working, I will definitely post back the results for anyone else looking for this.

    Speaking of... upon further testing I get the same result in Ableton by just passing midi values to it: Only 1 LED at a time and that one doesn't turn off until the next one is lit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •