Traktor S4 MK2 won't power on
Results 1 to 9 of 9
  1. #1
    Newbie
    Join Date
    Mar 2014
    Posts
    1

    Default Traktor S4 MK2 won't power on

    Today I tried turning on my Traktor S4 and once the light turns on it turns off right away. The only light I see is from the Master near the Dry wet knobs.

    Does anyone know what happened to my controller? It recently worked for me a couple of days ago until today...

  2. #2
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    6,934

    Default

    Sounds like a hardware issue but let's hope it's not the USB socket... How about the MIDI mode LED's? See if some other computer/cable would work. If it's the same, then re-install everything.

    NI support can help you with this if you tell them your complete configuration details.

  3. #3
    Tech Wizard Xander1's Avatar
    Join Date
    Mar 2014
    Location
    Scotland
    Posts
    72

    Default

    Run the setup wizard in controller manager?
    S4+3D=FUN

  4. #4
    Tech Guru antifmradio's Avatar
    Join Date
    Jun 2009
    Location
    NJ NYC
    Posts
    1,149

    Default

    Also plug the adaptor directly into A DIFFERENT outlet in the house and see if it stays.
    You could be getting some kind of spike from the outlet or POWER STRIP you are using.
    If you are in a power strip its possible that a few of the sockets arent working correctly or are turning off because they see too much voltage load, which is what some modern power strips do to avoid over heating, damage to equipment, and fires

  5. #5
    Tech Wizard Xander1's Avatar
    Join Date
    Mar 2014
    Location
    Scotland
    Posts
    72

    Default

    Quote Originally Posted by antifmradio View Post
    Also plug the adaptor directly into A DIFFERENT outlet in the house and see if it stays.
    You could be getting some kind of spike from the outlet or POWER STRIP you are using.
    If you are in a power strip its possible that a few of the sockets arent working correctly or are turning off because they see too much voltage load, which is what some modern power strips do to avoid over heating, damage to equipment, and fires
    Dont think it has anything to do with the power because what he has described is what happens when you turn it on but dont have traktor opened.
    S4+3D=FUN

  6. #6
    DJTT Ninja Mod tekki's Avatar
    Join Date
    Apr 2008
    Location
    Afterhour Ali's lap
    Posts
    11,005

    Default

    Quote Originally Posted by Stewe View Post
    Sounds like a hardware issue but let's hope it's not the USB socket...
    It is.

    Most probably the orange pin divider block in the B Connector is missing.

    In short, this is missing:


    From this:


    This can be fixed by cutting up a thin piece of cardboard to seperate the top pins from the bottom:


    Ofcourse the cardboard ninja mod is a temp solution (which I m using for quite some time now myself), the best bet is to have the connector itself replaced)

    For this you can go to NI or the (web)shop for guarantee repair, or to put in a new connector yourself.
    RSTRCTD | twitter | facebook (RSTRCTD) facebook (LJ) | vimeo | pinterest | my studio | soundcloud (RSTRCTD)| soundcloud (LJ)
    -- CHECK our DEBUT (DEEP)HOUSE EP RELEASE ON BEATPORT "RSTRCTD - EXISTENCE" --

  7. #7
    Newbie
    Join Date
    Aug 2017
    Posts
    2

    Default

    Did you get i worked out?
    I have the exact same problem now!!!

  8. #8
    Newbie
    Join Date
    Sep 2017
    Posts
    1

    Default

    Quote Originally Posted by DJ4300 View Post
    Did you get i worked out?
    I have the exact same problem now!!!
    I now have the exact same problem with my S4, lights up for a second and then turns dark (except for usb light) and won't work. Has anyone encountered a solution?

  9. #9
    Newbie
    Join Date
    Aug 2017
    Posts
    2

    Default ........

    Quote Originally Posted by hilary View Post
    I now have the exact same problem with my S4, lights up for a second and then turns dark (except for usb light) and won't work. Has anyone encountered a solution?
    Re install your control center from traktor

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •