Xone:K2 + Traktor - Soft Takeover Problems?
Results 1 to 5 of 5
  1. #1

    Default Xone:K2 + Traktor - Soft Takeover Problems?

    Really bugging me - maybe someone out there has had a similar experience and can help?

    I love my Xone:K2. Bought it, mapped the everloving hell out of it (layer 1: 4 deck mixer and loop control, layer 2: 4 unit FX + hotcue control, planning layer 3: remix deck control).

    I have 3 mappings, one for each layer, and on each mapping I've mapped the line faders to control deck volume CABD. So that's the one constant across all layers. However, when switching layers, the takeover somehow glitches. It doesnt matter if I've checked or unchecked the 'soft takeover' option, it just doesn't work. Oddly enough, I have to push the fader to one limit or another to get it to 'wake up', which can then mean a jump or a dip in volume as I go to 'catch' the control and bring it back to what it was. Sometimes I have to 'wake it up' at the top of the fader, sometimes at the bottom.

    Obviously this is really annoying. Anyone else experience this? Any way to map around or fix this? I figure it has something to do with the fact that I'm using 3 mappings on the same channel, + the firmware of the device itself that treats the faders as different midi notes when I switch layers.

    It doesn't seem to happen with the encoders, but that may be because those aren't mapped to the same thing across all layers.

    You can hear me struggling with this in the first 5 minutes of this mix: . I have the acapella from Logic - The Warning running, and I have to slam the fader down and then back up to catch it for the fadeout - you can hear the dip during the lyric "Red rose or black"

  2. #2
    Tech Mentor Michielygil's Avatar
    Join Date
    Jun 2008
    Location
    Dordrecht, The Netherlands
    Posts
    455

    Default

    It's because it has an internal soft take over. I have the same thing; have volume and eq's as a constant on all three layers.
    Just wish there was a sixth layer where you get all the buttons plus the encoders as new. Kinda like Layer 4+.

    I am on a mission to find out if you can turn off the built in soft take over, will let you know.
    2x A. Audio HTD 4.5 | Sony MDR 7506 | Xone:4D | Sony Vaio E i7 | 2x KRK 8 | Traktor Scratch Pro 2 | Launchpad | NI Maschine | NI Komplete 8 | Ableton Live 9

  3. #3

    Default

    Quote Originally Posted by Michielygil View Post
    It's because it has an internal soft take over. I have the same thing; have volume and eq's as a constant on all three layers.
    Just wish there was a sixth layer where you get all the buttons plus the encoders as new. Kinda like Layer 4+.

    I am on a mission to find out if you can turn off the built in soft take over, will let you know.
    Thanks, keep me posted if you find something out!

  4. #4
    Tech Mentor Michielygil's Avatar
    Join Date
    Jun 2008
    Location
    Dordrecht, The Netherlands
    Posts
    455

    Default

    I've found a workaround, since there is no option to turn off the internal soft take over of the K2.

    The layer switch button also sends out a midi signal, so you can use that to have a modifier state connected to a layer.

    For instance, I have modifier 3 connected to it, with the red layer connected to value 0, amber layer to 1 and green layer to value 2.

    Then I use Latching layer type 4, where only all the buttons get a new value per layer.

    This way, the volume faders, encoders and pots get the same value in each layer. Now in my case I want the encoders to do something different with each layer, so I map all the functions I want to the encoders, but add the modifier 3 value as a precondition for each function.
    You can do the same with the pots, but keep in mind that you might want to use soft take over from Traktor there for obvious reasons.

    Hope I explained it properly, if you have any questions, please ask. Goo luck!
    2x A. Audio HTD 4.5 | Sony MDR 7506 | Xone:4D | Sony Vaio E i7 | 2x KRK 8 | Traktor Scratch Pro 2 | Launchpad | NI Maschine | NI Komplete 8 | Ableton Live 9

  5. #5
    Newbie
    Join Date
    Nov 2014
    Posts
    1

    Default

    Quote Originally Posted by Michielygil View Post
    I've found a workaround, since there is no option to turn off the internal soft take over of the K2.

    The layer switch button also sends out a midi signal, so you can use that to have a modifier state connected to a layer.

    For instance, I have modifier 3 connected to it, with the red layer connected to value 0, amber layer to 1 and green layer to value 2.

    Then I use Latching layer type 4, where only all the buttons get a new value per layer.

    This way, the volume faders, encoders and pots get the same value in each layer. Now in my case I want the encoders to do something different with each layer, so I map all the functions I want to the encoders, but add the modifier 3 value as a precondition for each function.
    You can do the same with the pots, but keep in mind that you might want to use soft take over from Traktor there for obvious reasons.

    Hope I explained it properly, if you have any questions, please ask. Goo luck!

    Hi Michielygil,

    I have experienced the same issue as the OP. Your workaround seems quite clever. I am gonna give it a go. Thanks for your input.

    Regards
    Olivier

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •