Completely stuck trying to use USB soundcard to cue tracks.
Results 1 to 5 of 5
  1. #1

    Default Completely stuck trying to use USB soundcard to cue tracks.

    Im using a macbook pro (mavericks), a DJ Control MP3 E2, and a Sweex 7.1 USB soundcard.

    I basically want to use the soundcard to cue up the mixes, and then use the in built audio on my mac to listen to the master sound. For the life of me I cant get it to work. If anyone could help I'd be ridiculously grateful. Cheers guys.

  2. #2
    Tech Guru
    Join Date
    Nov 2012
    Location
    FL, USA
    Posts
    2,122

    Default

    Make sure your audio routing is correct.
    Bedroom DJ | Pioneer DJM-800 | Pioneer CDJ2000 and CDJ900-NXS | 2 x Mackie MR8MKII | Sennheiser Amperior

  3. #3
    Tech Guru Patch's Avatar
    Join Date
    Dec 2008
    Location
    Bristol, UK
    Posts
    6,375

    Default

    I'm not a Mac user - but the term "aggregate device" springs to mind.

    http://support.apple.com/kb/ht1215

    You will "aggregate" your built in audio and your USB audio devices into a single "aggregate" device, which you should be able to select in Traktors preferences and assign one as maser, and one as cue out.

    EDIT: In fact, you SHOULD be able to set up a total of FOUR stereo outs (3 from teh USB, and 1 from the built-in sound card).

    EDIT2: You shouldn't even need to aggregate your devices. Just select the relevent stereo ppair from the USB card in Traktors preferences...
    Last edited by Patch; 10-15-2014 at 01:11 PM.
    DJ'ing: 2x1200MK2, DJM 850, Dicers, F1, Zomo MC-1000, Sony MDR-v700, i7 Win 10 HP Envy
    Production: Ableton Live 8 and a mouse, Sennheiser HD400, Sony VAIO

    Click HERE to D/L Free Tracks from Soundcloud!!!
    https://www.facebook.com/Patchdj

  4. #4

    Default

    Cheers for the replies. I'm not sure if its as I cant get the drivers for the soundcard on mac. It gets picked up as USB sound card on my mac, but not the make. In Traktor I selected the Aggregated device. Tried all didd routing combination and still it seems that the sound card only controls my macs sound, I can't separate it

  5. #5
    Tech Guru deevey's Avatar
    Join Date
    Oct 2010
    Location
    From Ireland Living in Manila: Philippines :D
    Posts
    3,672

    Default

    On 7.1 cards on the Mac, you need to specify you are using all the channels on a sooundcard or it defaults to stereo

    You need to go into audio/midi setup and click your USB soundcard

    From the dropdown menu which probably currently says 2 ch 16bit integer you should be able to choose 4ch 16 bit integer (or similar).

    Now 4 channels will be enabled and you can choose them in your dj software.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •