A&H Xone 92 problem!?
Results 1 to 7 of 7
  1. #1
    Tech Guru Superfreak's Avatar
    Join Date
    Jun 2012
    Location
    London, UK.
    Posts
    640

    Default A&H Xone 92 problem!?

    My xone 92 has been collecting dust in my studio for a good 6months+, as my Audio 10 soundcard broke and I haven't sent it off to be repaired yet, so haven't mixed in a while.

    Hooked up some turntables recently and I've noticed that the left channels of EACH and every channel of the xone 92 isn't working.. There are 4 channels altogether. When I unplug one of the RCA's from a channel, there is no sound, let's say the white rca, but when I unplug the red rca, sound still plays... It should still play regardless of which one of the two sides is plugged in...

    I'm really not sure what has caused/is causing this, is it broken? Or am I missing something!?

    I've tried two different and working needles on the TT's, problem still persists, tried different pairs of RCA cables, which all do work, problem still persists....

    Is this a known problem? I haven't used my mixer in nearly a year, it's well looked after, what on earth could of made this happen!?

    I'm in financial difficulties at the moment, so I had planned (I feel like crying and inside I i'm sobbing) sell my mixer, on gumtree or ebay, need some money right now. Very hard for me to do this but, you know how it is sometimes...

    SO... I want to make sure that I'm not selling a broken mixer....

    Help please!

    Thanks
    Last edited by Superfreak; 02-02-2015 at 12:34 PM.
    Roland TB-3, Roland TR-505, Maschine MK1 2.0, Alesis VI25, Novation Impulse 25, Allen & Heath ZED 10, iMac 2.9 GHz i5 8GB RAM, MBP 15" 2.66GHz, Logic Pro 9, Logic Pro X, Ableton Live 8, Ableton Live 9, KRK Rokit 8 G5's, Editor Keys Monitor Guards, Traktor Scratch Pro 2, Audio 10, , Vestax PDX-d3s x2, Kontrol X1 x2, Lexicon Alpha USB Audio Interface,

  2. #2

    Default

    In the first line you mentioned collecting dust. This is like your number one enemy. Never let expensive electronics collect dust.always cover and Use dust off, or even better , an electric duster, on any electronics you expect to last. Dust off regularly!


    Have you checked both channels of the main? If every channel playing only right or left, it could actually be the main.. Try one of the other outs on the mixer....


    As a last resort , most good manufacturers will refurb your mixer, fix shorts, clean pots etc, for like 50 bucks. At least rane does that...
    Traktor/Ableton /Komplete /MBP OSX el capitan

    http://www.soundcloud.com/deejaesnafu

  3. #3
    Tech Guru 031999's Avatar
    Join Date
    Sep 2011
    Location
    NYC, NY, USA
    Posts
    1,340

    Default

    I recommend you GENTLY partially take it apart, and give it a little air dusting. If possible just use pure compressed air, but if you must use canned air. Then down tilt or turn the can because you don't want any frost or moisture to get in there.

  4. #4
    Tech Guru space monkey's Avatar
    Join Date
    Mar 2009
    Location
    back home
    Posts
    1,169

    Default

    THe schematic (this is from my memory) on the 92 should have each channel on its own board which is then sent to the master (with some routings to account for send/return filters etc...) so if there is something amiss then you may want to start with your outs, ie. balanced and unbalanced. Try sending from the various output (XLR and RCA/record out) to see if there is a pattern.

  5. #5
    Tech Guru 3heads's Avatar
    Join Date
    Mar 2010
    Location
    Leipzig, Germany
    Posts
    1,379

    Default

    Don't take this the wrong way, but could you have hooked it up the wrong way by accident? The Xones have the RCA pairs horizontally opposed to most other mixers. I've had way too many stupid little things like this throwing me off when hooking up to rule out something this simple (you know, the usual - dry/wet knobs on the 42 set to 12 o'clock instead of completely dry, a filter still engaged, cross fader not in the middle).
    13,3" MacBookPro (Mid 2012) # 2x Technics 1210 # NI Audio 8 DJ # Ecler Nuo 2.0 # NI Traktor Kontrol X1 # Sennheiser HD-25
    http://soundcloud.com/vincent-lebaron/

  6. #6
    Tech Guru 031999's Avatar
    Join Date
    Sep 2011
    Location
    NYC, NY, USA
    Posts
    1,340

    Default

    oh yeah also keep in mind like 3heads said, the xone rca's are side by side, most mixers are above and below.

  7. #7
    Tech Mentor
    Join Date
    May 2011
    Posts
    164

    Default

    I suspect the same. make sure you have connected the RCA's horizontally and not vertically.
    Also, the top row is phono and the bottom row is line.

    My 92 collected dust for months on end but never malfunctioned. Also the chances of ALL the left channels going out is slim.
    Definitely look at the back and the make sure your RCA jacks are not RED ABOVE WHITE, and rather RED next to WHITE......

    Also, its extremely common to make such errors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •