NI Account and Service Center down?
Results 1 to 4 of 4
  1. #1
    Tech Mentor
    Join Date
    Jun 2011
    Location
    NJ USA
    Posts
    219

    Default NI Account and Service Center down?

    Anyone else having trouble logging into their Native Instruments service center?
    Was looking to see if there were updates, but it crashes on OS X when logging in.
    Tried logging in on the website, and it doesn't work either.
    Would send them a request via the support link, but it requires you log in

  2. #2
    Tech Guru robdquick's Avatar
    Join Date
    Aug 2011
    Location
    Bristol, UK
    Posts
    590

    Default

    Just managed to log in with my account on their website, and the service centre loads and logs in on my windows laptop.
    Mobile DJ. 2 x Denon SC2900, Denon MC-6000 MK2, Wharfedale Titan 15a Powered Speakers, Titan A15 Subs, HP laptop. Shed load of lights!! Maschine Mikro MK2, Xone:K2.

    2nd Generation Mobile DJ
    2G on Twitter | 2G on Facebook
    | RobDQuick On Soundcloud


  3. #3

    Default

    i also logged into the website no problems.


    any chance your using the wrong pw?

    have you tried logging into the website with a different browser?
    Traktor/Ableton /Komplete /MBP OSX el capitan

    http://www.soundcloud.com/deejaesnafu

  4. #4
    Tech Mentor
    Join Date
    Jun 2011
    Location
    NJ USA
    Posts
    219

    Default

    Just tried now and it works. I was logging in from the app on OS X and through Safari.
    I did get an email from them about the update to their Rounds software, so maybe there was database maintenance going on at the time.
    Was kind of hoping it was an cool update to something else, though

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •