Broken Encoder, VCI-400
Results 1 to 8 of 8
  1. #1

    Default Broken Encoder, VCI-400

    Hey, guys.

    New DJ, new to DJTT (But have appreciated all of the advice!).

    I have a VCI-400 that is my pride and joy, but one of the encoders is not working. If I turn the encoder to the left, it gives me the proper value of 127 for its specific CC, but will alternate between 1 and 127 when I turn it to the right.

    It's on the left side, the left of the two knobs under the dedicated FX knobs. I thankfully haven't had a mapping where I needed it, but I'm planning a massive mapping overhaul for my Vestax, and really would love to try to implement it.

    I had a similar issue with the browser encoder, but taking my Vestax apart and using an electrical-component-sensitive dust removing spray resolved the issue for that knob, but not for the one I'm still having trouble with.

    Will re-installing the firmware fix the issue?

    Thanks,
    Alan Wayside

  2. #2
    Tech Guru the_bastet's Avatar
    Join Date
    May 2012
    Location
    Cincinnati, OH
    Posts
    2,750

    Default

    Did you ever figure out a fix for this? Usually cleaning the encoder will resolve the issue.

    In this order (from simplest to hardest fix)
    Flash firmware
    Clean encoder
    Replace encoder

  3. #3

    Default

    Quote Originally Posted by the_bastet View Post
    Did you ever figure out a fix for this? Usually cleaning the encoder will resolve the issue.

    In this order (from simplest to hardest fix)
    Flash firmware
    Clean encoder
    Replace encoder
    Dumb question - how do I go about flashing the firmware on a Mac?

  4. #4

    Default

    That makes sense.

    I've already cleaned the inside, I guess I'll look into the firmware.

    I went here;

    https://support.serato.com/hc/en-us/...s-and-Firmware

    I downloaded the installer, I downloaded the new firmware. I made sure to turn the VCI-400 on in it's upgrading mode and ran the program.

    Upon dragging the audio file (as specified), it gave me the following error.
    Screen Shot 2016-07-05 at 1.41.30 PM.jpgScreen Shot 2016-07-05 at 1.41.11 PM.jpg

    Is there another way to reset the Vestax? I may need to do that first.

    Thanks guys. I appreciate this.

  5. #5
    DJTT Administrator del Ritmo padi_04's Avatar
    Join Date
    Nov 2009
    Location
    Argentina
    Posts
    6,493

    Default

    Quote Originally Posted by Alan Wayside View Post
    Dumb question - how do I go about flashing the firmware on a Mac?
    You can't unless you install an older version of OS X which the updater works with or you install Win via Bootcamp/Paralells.

  6. #6

    Default

    I heared that VCI400 sometimes got problems with knobs and faders. I think there is no way out but changing them

  7. #7
    DJTT Administrator del Ritmo padi_04's Avatar
    Join Date
    Nov 2009
    Location
    Argentina
    Posts
    6,493

    Default

    All controllers and mixers do over time, it's just regular wear. Keep in mind the 400 is as old as the original S4 so things are bound to go wrong after so long.

  8. #8
    DJTT Administrator del Ritmo padi_04's Avatar
    Join Date
    Nov 2009
    Location
    Argentina
    Posts
    6,493

    Default

    Btw! This manual shows how to open up the unit to actually replace the part. I've had no luck tracking the part number and in all honesty getting the exact spare might be close to impossible these days. I'd go out hunting for a brick unit you can salvage components form if you really want to stick to the 400.

    VCI-400 Service Manual

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •