Loop Recorder Traktor in External Mixing mode
Results 1 to 8 of 8
  1. #1
    Tech Convert
    Join Date
    Mar 2015
    Posts
    17

    Default Loop Recorder Traktor in External Mixing mode

    Hi all. I have a Denon DJ DN-X1600 as mixer and soundcard. I use traktor in external mixing mode.
    I use 4 channels: Deck A and B, one sample deck (a deck D in Traktor) and one channel dedicated for the loop recorder (would be deck C)
    Now I have troubles setting up the loop recorder. I don't get any sound, so not sure what goes wrong where. Maybe the recorder isn't recording input. And/or maybe the recording doesn't make it back into deck C...
    The mixer also has an effect called Send/return. Didn't figure out yet if that is of some use.

    On Internal mixing, everything is fine, although the sound output is not dedicated to deck C. It's just 'somewhere' in the whole mix.

    I tried a bit this info https://traktorbible.com/articles/lo...ixer-mode.aspx. Mark the comment I think it's worth pointing out that if you have a Traktor certified mixer like the DNX-1600 all you have to do is assign the channels to the appropriate input and outputs.

    Well...about that
    Any advice would be great!

  2. #2
    Tech Guru SlayForMoney's Avatar
    Join Date
    Mar 2012
    Location
    EU
    Posts
    1,687

    Default

    What channel (or master?) you want the loop recorder to record? Give us a screenshot of your Traktor input and output routing
    Denon X600 - 2x Denon SC-2000 - AKG K181DJ - NI Audio 2

  3. #3
    Tech Convert
    Join Date
    Mar 2015
    Posts
    17

    Default

    Quote Originally Posted by SlayForMoney View Post
    What channel (or master?) you want the loop recorder to record? Give us a screenshot of your Traktor input and output routing
    I'd like to record the master, but if that's not possible, I'll settle for one deck, like deck A.
    I'd followed the same routing as the Traktor Bible article mentioned above. I left both C and D deck empty.
    Mixing mode is set to external. Only option to record in the loop recorder is EXT (so no CUE or MASTER options on Internal Mode) Soundcard is set to Asio DN X1600. The mixer has a Send/return Fx, but that's more to send sound of external fx units. Don't think that's necessary (and no extra cables are plugged into the send/return busses) since all sound is carried between Traktor and mixer via one USB cable.
    Should the deck that receive the loop recorder be set to Live input? Or Track deck?

    Here's the input


    Here's the output.


  4. #4
    Tech Guru SlayForMoney's Avatar
    Join Date
    Mar 2012
    Location
    EU
    Posts
    1,687

    Default

    Make sure that your mixer is set to send master output (that would be basically the "rec") on the 7/8 usb channels.
    How to do that is described here (when you compare, it's basically the same process, internal routing of output into a input): https://support.native-instruments.c...Denon-DN-X1600
    Denon X600 - 2x Denon SC-2000 - AKG K181DJ - NI Audio 2

  5. #5
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    7,348

    Default

    What Input do you use for the loop recorder? Is it set to Main?

  6. #6
    Tech Convert
    Join Date
    Mar 2015
    Posts
    17

    Default

    Quote Originally Posted by SlayForMoney View Post
    Make sure that your mixer is set to send master output (that would be basically the "rec") on the 7/8 usb channels.
    How to do that is described here (when you compare, it's basically the same process, internal routing of output into a input): https://support.native-instruments.c...Denon-DN-X1600
    Woops, slow relply! This was definitely the problem.The DN-X1600 could use a how-to guide, it's all in bits and pieces all over the net Anyway, I now have a small latency problem. Once the looprecorder is done recording, he start playing automatically...but out of sync. So I have to press 'stop', wait a couple of beats and try to hit play on the right moment, a bit hard...Any ideas how to sync the looprecorder with the rest of the mix?

  7. #7
    Tech Guru SlayForMoney's Avatar
    Join Date
    Mar 2012
    Location
    EU
    Posts
    1,687

    Default

    Quote Originally Posted by wacomole View Post
    Woops, slow relply! This was definitely the problem.The DN-X1600 could use a how-to guide, it's all in bits and pieces all over the net Anyway, I now have a small latency problem. Once the looprecorder is done recording, he start playing automatically...but out of sync. So I have to press 'stop', wait a couple of beats and try to hit play on the right moment, a bit hard...Any ideas how to sync the looprecorder with the rest of the mix?
    Use sync? No, really. I have not used loop recorder but doesn't Traktor automatically analyzes the recorded content to get the bpm and grid data and saves like a track into your collection? Seems logical that sync would work on the playback of it if it's enabled....

    Also...internal re-routing of audio in a mixer with internal sound interface is kind of a advanced thing but as you can see it's on the Traktor's webpage and also in your mixer's manual (page 21). Manufacturers can offer many features (and X1600 is packed with them, wait till you start adjusting EQ crossover points and other stuff..) but they cannot provide a how-to guide of every feature because it can be used in many ways and depends on what software you're using it with. Have you set Traktor to send bpm info to your mixer via midi? Basically, you get external FX's synced to Traktor's bpm info. Pioneer mixers don't have that, they can only recieve bpm info from rekordbox.
    Denon X600 - 2x Denon SC-2000 - AKG K181DJ - NI Audio 2

  8. #8

    Default

    If QUANT is enabled, REC and PLAY function of the Loop Recorder should sync with the clock and the virtual grid. Haven't tried this externally though.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •