Midi Fighter 3D Flashing Red Lights / Cannot Reset
Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2017

    Question Midi Fighter 3D Flashing Red Lights / Cannot Reset

    I have a Midi Fighter 3D MF-005 and its not being recognized in Windows 7 or Windows 10.

    There is one white light bar on the top left. And one button on the bottom left that lights after you press the next button.

    I tried to hold 4 corner buttons and I eventually got all buttons flashing RED. No checkboard.

    I looked at a couple threads and the FAQ about resetting and when I opened it to attempt manual boot I noticed that the board is completely different. The RESET and BOOT are on either side of the USB port on my version.


    What do I have to do to re-up the firmware without having to take it completely apart to get to the opposite side of the board? I didn't see any micro-switches on the bottom of the board. I tried jumpers and it didn't do anything as far as USB hardware was concerned in Device Manager.

  2. #2
    DJTT Administrator del Ritmo padi_04's Avatar
    Join Date
    Nov 2009


    Hey Denetus,

    If the unit has the top right bank button lit and the arcade buttons turn red after a while it means it's in factory test mode. To fix this all you need to do is press each lit button in sequence starting with the bank buttons, then side buttons and finally the arcade buttons, then it will exit factory test mode and work normally. If you keep getting the flashing red lights it's means that you are taking too long to press then, disconnect your unit and try again.

    In the event that one of the buttons fails to acknowledge then it means you have a faulty switch on your device.

    Troubleshooting guides for other models are NOT compatible with your 3D so if you did try to load a recovery firmware file for a different model there is a high chance you might have bricked it.

    The best way to get your Midi Fighter issues sorted is to send an email to support@djtechtools.com and we'll get back to you within the next business day.

  3. #3
    Join Date
    Apr 2017

    Default Fixed

    So I was able to get it to go through the entire process after I hit the first button quick and went through the side buttons and the Sanwas. Either the top bank switches are hard to engage or there is something wrong with the firmwares switch polling time. I have seen this same sort of thing happen with Line6 X3 live foot switches.

    Please update your FAQs with the correct troubleshooting info. I am tech support and your documentation needs to be revamped to express the hardware revisions having different requirements. Also, what size are the micro switches needed to fill those 2 bottom switches just in case I need them?

    30 May 2013 is the firmware version.
    Last edited by Deneteus; 04-21-2017 at 03:57 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts