1210mk2 problem - 78 rpm, broken start/stop, start instantly
Results 1 to 2 of 2
  1. #1
    Tech Mentor decon's Avatar
    Join Date
    Mar 2010
    Location
    Denmark
    Posts
    204

    Exclamation 1210mk2 problem - 78 rpm, broken start/stop, start instantly

    Hi all,

    My 1210 mk2 just started to have this weird issue. When I turn on the turntable, both the 33 rpm and 45 rpm buttons lights up, and the platter spins at what looks like at least 78 rpm, could be more. The platter start turning instantly after turning on the TT. The start/stop does not seem to do anything.

    Here is a video of the problem

    I have no idea what to do about this, nor do I know what search terms I should be using for troubleshooting.

    Can anyone help a very sad tecnics owner?

  2. #2
    Tech Mentor elohyspoissonpilote's Avatar
    Join Date
    Oct 2015
    Location
    Paris
    Posts
    124

    Default

    Hi,
    I know this problem as I repair manu decks with that problem.
    The important things to know is that the problem can have different sources; from simple and quicly fixable, to more complicated. I just gicve you some indications, don't take it as a firm diagnosis.

    I rank it by the frequency I had it from the past decks I repaired with this problem.
    1st possibitlity: Most of the time, itis just a samll components identified by Q201 on mother board , wich can have only a bad dry solder, resulting from a false contact , or, it can be the component itself wich is faulty.
    2nd possibility If this component is OK, can be also the resistor just uponf the Q201 (Rxxx) with the same causes (dry solder or faulty components itself)
    3rd, it can be the chip AN6680, with same cause, bad solder on one or more of the 24 pins, or the chip itself (30$ on Ebay)
    4rd: more rarely, there is some other cause but never saw it by myself at the moment, just read from others.

    Here is the link to my Dedicated FB page where you can see some similar videos od decks I had recently to repair.

    PoissonPilote Technics 1200/1210 MK2 Support
    http://www.facebook.com/PoissonPilot...MK2Activities/

    Hope you can solved your problem

    Phil
    (I m franch so please don't expect to much from my english ;-)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •