NI Kontrol Z2 Mapping for Rekordbox DJ - Page 4
Page 4 of 4 FirstFirst 1234
Results 31 to 34 of 34
  1. #31

    Default

    Ahhh okay it's working now, however the loop funct doesn't work? And a little bit of the master song plays through the headphones when cueing a song? Also how do I switch too Live input for Vinyl? So complicated this I'm thinking of returning this mixer and getting a pioneer this is soo complicated for what it is

  2. #32
    Tech Wizard
    Join Date
    Jan 2018
    Posts
    33

    Default

    Most of the trouble you're having is with the software because the mixer was never intended for Rekordbox so it's not plug and play like with Traktor. But once it's all set up it works well.
    For the loops not working, make sure you're in relative mode, it won't work in absolute. Rekordbox is not like Traktor where it automatically switches from absolute to relative when you hit a loop or hot cue.
    As for the master through the headphones, you have to open up the software mixer (check the mixer box at the top next to sampler) and turn the 'MIXING' knob all the way to the left, and the LEVEL knob all the way to the right. This you have to do once everytime you open up the software but I have actually mapped those two knobs to the Z2 shift+low eq knobs left and right so you can do it quickly.

  3. #33

    Default

    Ahhh thanks think that's everything working for now lol!

  4. #34
    Newbie
    Join Date
    May 2018
    Posts
    1

    Default

    I can confirm the mapping works as intended.

    However to make the 'autoloop' function on your rotaries to work accordingly, I had to go to my Controller Editor:
    Select Template -> Assign tab -> Select rotary -> make sure Turn Mode is set to 'relative' on both rotaries.
    The same goes for the Browse rotary. Otherwise it'll just go in one direction...

    Plus, go to your Rekordbox settings -> Controller tab -> Deck tab -> Scroll down to AUTO BEAT LOOP -> 'Loop for specified beats.'

    The headphone section is probably the one thing most people want to map the way they want it...
    My setup is:
    Sync buttons A & B for cue selection.
    Deck C volume knob for headphone level, Deck D knob for Cue/Master.

Page 4 of 4 FirstFirst 1234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •