MIDIfighter Twister Utility v2.70 Detection Loop on macOS Sierra (10.12.6) on 2 MBPs
Results 1 to 3 of 3
  1. #1
    Tech Student
    Join Date
    Feb 2018

    Question MIDIfighter Twister Utility v2.70 Detection Loop on macOS Sierra (10.12.6) on 2 MBPs

    Hi all,

    I purchased a MIDIfighter Twister yesterday and ran the MIDIfighter Utility v2.70 on two Mac Book Pros, both macOS Sierra 10.12.6. Detection loop on both machines: Initial screen tells me to plug in a single MIDIfighter unit. Doing so makes the screen briefly change into an editor interface. Upper left shows a scan of a firmware version in progress, which ends in showing a date ("26 Juli 2016") and small green label that says "Up to date". Very hard to grasp, because the screen lasts for only a second and then immediately flips back to the initial screen. This goes on endlessly.

    It happens on both of my Mac Book Pros: Plugged the unit directly into the Late 2015 model (production machine) with all other USB hardware removed. No interfering software ran to my best knowledge. It's my stable production machine that has more than 10 USB/MIDI/audio devices running simultaneously without issues. Same on my Mac Book Pro 2017, (current model, USB C/Thunderbolt 3 interfaces) using an elgato Port replicator.

    The hardware itself seems to work because MIDI monitor shows proper output when operating the unit. I really, really like the hardware but in it's current state it is unusable for me. Any ideas regarding this issue?

    Greetings from Germany,


    UPDATE: Issue seems to be related to Sierra (macOS 10.12): Briefly tried an older 27'' iMac (Late 2013) with High Sierra (macOS 10.13.3). Twister gets found, no detection loop...
    Last edited by kmm; 02-23-2018 at 12:54 PM. Reason: Tried more hardware

  2. #2
    Tech Convert
    Join Date
    Jul 2018

    Default same problem here

    Hi all,

    Same problem here ,
    cannot find a fix for macos 10.13.5
    is there a working update somewhere ?
    Last edited by kostra0ne; 07-15-2018 at 01:29 AM.

  3. #3
    Tech Convert
    Join Date
    Jul 2018

    Default seem related to app

    Hi folks,

    i got the same bug on a 2017 macbook pro
    stuck in the check update loop of hell ...
    my new device is also working on older hardware (macbook pro 2013) on the same os (10.13.6)

    gonna post a new thread,

    help would be nice


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts