Midi Fighter Twister not playing nice with Launchpad Pro
Results 1 to 4 of 4
  1. #1
    Tech Convert
    Join Date
    Mar 2018
    Location
    Gainesville, GA
    Posts
    16

    Default Midi Fighter Twister not playing nice with Launchpad Pro

    While using my Twister and Launchpad Pro together, Iím noticing that some of the signals I send with the Twister are causing some of the function buttons (Solo, Track Select, etc.) on the LPPro to change color, which renders them useless. Iím assuming some of the midi signals coming from the Twister are crossing with some of the values that change the color of the LPPro buttons? Does anyone have any experience with this issue or maybe could suggest a work around? I would love to be able to use these two controllers at the same time.
    Ableton - Launchpad Pro - Midi Fighter 3D - Midi Fighter Twister

    http://SoundCloud.com/joshlikesdrums

  2. #2
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    7,332

    Default

    Probably the both hardware are sharing the same midi message and channel. Try switching your Twister to a different midi channel via the Midifighter Utility.

  3. #3
    Tech Convert
    Join Date
    Mar 2018
    Location
    Gainesville, GA
    Posts
    16

    Default

    Thank you for the suggestion! So I tried that just now, and it's reacting to every channel (and I tried all four banks). Also, I was able to figure out that all of the messages were associated with the color changes of the perimeter buttons of the LP Pro. As I cycled through the channel of the Twister, I worked my way around the Pro. Does this mean there may not be a solution?
    Ableton - Launchpad Pro - Midi Fighter 3D - Midi Fighter Twister

    http://SoundCloud.com/joshlikesdrums

  4. #4
    Tech Convert
    Join Date
    Mar 2018
    Location
    Gainesville, GA
    Posts
    16

    Default

    Okay, so I know this was a while ago but I've been revisiting this issue from time to time with possible solutions and I think I finally found something that works. Since the Twister and the LP Pro share CC messages, you have to turn off "Remote" from the LP Pro's Input and Output ports (the Standalone and MIDI ports don't really affect it, so those settings can remain unchanged). The only drawback with this is that you basically lose the User mode functionality of the LP Pro, which isn't a huge deal for me because any parameter mapping that would be done in User mode is being done with the Twister instead. I'll be working in Ableton for most of the day today so I'll report back if this causes any other issues. Thanks for your help!
    Ableton - Launchpad Pro - Midi Fighter 3D - Midi Fighter Twister

    http://SoundCloud.com/joshlikesdrums

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •