s4 not working with TSP 2.6.8 new build
Results 1 to 10 of 10
  1. #1

    Default s4 not working with TSP 2.6.8 new build

    I have just rebult my laptop with a fresh 2.6.8 install as I want to use this to test the Pioneer DDJ SX2 with
    1st up i wanted to make sure TSP was working properly with my S4 MK2.
    The drivers are installed and I have updated the Controller Editor as well
    But the S4 is completely unresponsive , nothing works on it at all
    If i play a track off the laptop the sound will output through the controller but thats it
    I have checked in Audio Set up that it sees the controller and it does

    What could be wrong?

    TIA Bart

  2. #2

    Default

    Check the release date of the 2.6.8 and the s4mkII. I assume, the mkII came out AFTER 2.6.8 was released, so no support for the machine. A friend of mine had the same troubles but it was Tp 2.5 so i can't be sure about 2.6.8.

  3. #3

    Default

    268 has the s4 mk2 drivers as part of the installation so it can't be that.

  4. #4

    Default

    does it have the native mapping installed? do you see the S4-menu at the bottom of the preferences window?

    The audio setup only fixes on the soundcard and the inputs and outputs. the card is the same as the one inside the s4mk1 so that indicator may not necessarily indicate that traktor can run the HID-s4mk2 (mk1 and mk2 run two very different protocols regarding the knobs/buttons and led-feedback)

    edit: regardless of the s4mk2's functionality, can you get it to work with the Pioneer DDJ SX2?
    Last edited by Sulherokhh; 09-10-2018 at 07:31 AM.

  5. #5

    Default

    Yes it does and I can see it in the preferences window.

    I have used it with 268 before but this was on a laptop where I had a newer version of TSP installed and then downgraded to 268 as well

  6. #6

    Default

    Bummer. Well, i only have the usual ideas.

    Traktor On/Off, S4 On/Off. USB Plug In/Out. System reboot. Traktor reinstall. Drivers reinstall. Every combination.

    Edit: If it's a downgrade, maybe it has a mapping it can't read. go into the mappings list and delete the s4 mapping. Restart traktor. It should load the 2.6.8 version. Maybe then it will work.

  7. #7

    Default

    Lol tried those

  8. #8

    Default

    one last thing. check your version number (top right native instruments logo button) to see if you are actually on 2.6.8 and not something even earlier.

  9. #9

    Default

    Ok resolved it.
    Re imaged the laptop and reinstalled 268 from scratch and it works

    now trying to get the damn sx2 mapping to work grrrrrr

  10. #10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •