problem in Traktor: Delay Freeze
Results 1 to 4 of 4
  1. #1
    Newbie
    Join Date
    Jan 2019
    Posts
    5

    Default problem in Traktor: Delay Freeze

    So I use the Delay Freeze a lot.
    But it only works for me like 4 out 5 times.
    4 out o 5 times the Delay Freeze sounds exactly like it should. But there are some times that seams like TRAKTOR freezes for a second and sound gets muted. I filmed it so you can see. On the movie the first 2 times, it works fine, on the third you can ear the bug.
    Let me know what you think and what I can do to fix it.
    I tried it all: I've done the 1 button mapping with all the FX settings to the same key,
    Or even much simpler like in this video: I save a snapshot of the FX SINGLE with all the knows in the position I want, and the UNIT ON and FRZ button pressed, so when I change the effects chain from GROUP to SINGLE it activates the Delay Freeze.
    But I can never get this right. There is always that one time it messes up my song...
    I have a KONTROL X1 mk2, but this happens even with keyboard mapping, OR even with no mapping, just clicking on the computer.
    This happened on Traktor Pro 2.6.8 and it STILL happens on traktor 3.0.2

    MOVIE WITH THE BUG HERE:

    Please help... I make a fool of my self at least once a gig with this bug...

  2. #2
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    7,357

    Default

    Set your FX Unit Mode command to Button-Direct-Single (not Button-Hold-Single)

  3. #3
    Newbie
    Join Date
    Jan 2019
    Posts
    5

    Default

    Quote Originally Posted by Stewe View Post
    Set your FX Unit Mode command to Button-Direct-Single (not Button-Hold-Single)
    it is in Button-Direct-Single...
    I think the problem is that the delay must be ON for a bit before I can use FRZ... but that sucks because it takes 2 key presses...

  4. #4
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    7,357

    Default

    Quote Originally Posted by macsoft View Post
    it is in Button-Direct-Single...
    I think the problem is that the delay must be ON for a bit before I can use FRZ... but that sucks because it takes 2 key presses...
    Know what, there could be solution to this which involves virtual midi driver. Need to test this out but in theory it should work fine.

    Create a new Generic MIDI Device which is used only to send midi notes in to the MIDI Driver:

    In-Port = Any MIDI controller
    Out-Port = Midi Driver (IAC, midiLoop)

    Create second Generic MIDI Device which will serve as a receiver and midi note sequencer:

    In-Port = Midi Driver
    Out-Port = Midi Driver

    (Note that both In and Out port is set to a MIDI Driver which means that once the signal enters it can loop endlessly allowing for all king of tricks)

    Once signal is received it triggers a series of midi events (i.e. trigger a quick sequence of Ch.7.CC.001 to Ch.7.CC.007 in just a split second). Then I should be able to take that first note and map it to Change the FX Unit mode to "Single" fx mode and my last CC in a chain should Insert + Activate + Set Parameter values.

    Release the button and FX Unit mode goes back to "Group" fx mode.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •