MAPPING 2 * Xone K2 for 4 decks control
Results 1 to 4 of 4
  1. #1
    Newbie
    Join Date
    Jan 2019
    Posts
    4

    Default MAPPING 2 * Xone K2 for 4 decks control

    (I just changed from my Xone 1D and 2D where i did't have this problem because it were two different devices)

    It should be not that difficult but i've got the following question:

    I have two Xone K2 controllers with which I want to map the midi. 1 of the controllers must control deck A and C and the other deck B and D. How can I make sure that one K2 (say k2-1) controls A and C and the other K2 (say k2-2) B and control D. If I now program a midi signal on the K2-1, the same thing happens with the K2-2.

    Is there a possibility to give my k2-1 and k2-2 an ID so that I can split it? Or is there an other way to fix this?

    Thanks a lot.

  2. #2
    Tech Guru astromech's Avatar
    Join Date
    Jun 2009
    Location
    West Yorkshire
    Posts
    1,674

    Default

    Quote Originally Posted by Errobix View Post
    (I just changed from my Xone 1D and 2D where i did't have this problem because it were two different devices)

    It should be not that difficult but i've got the following question:

    I have two Xone K2 controllers with which I want to map the midi. 1 of the controllers must control deck A and C and the other deck B and D. How can I make sure that one K2 (say k2-1) controls A and C and the other K2 (say k2-2) B and control D. If I now program a midi signal on the K2-1, the same thing happens with the K2-2.

    Is there a possibility to give my k2-1 and k2-2 an ID so that I can split it? Or is there an other way to fix this?

    Thanks a lot.
    Change the MIDI channel for one of them and map to that.
    A&H Xone:62 | 2 x NI Kontrol X1 MK2 | 2 x 1210s | TSP2 | Audio 10 | Apple Macbook Pro 13 inch | Sennheiser HD7 DJ | Ableton Push
    read: http://djworx.com/author/dan-morse
    talk: http://facebook.com/bleeptechno
    listen: http://mixcloud.com/bleephudds

  3. #3
    Newbie
    Join Date
    Jan 2019
    Posts
    4

    Default It worked!

    I changed the midi channel of one of them and that solved the problem

    Thanks a lot!

  4. #4
    Tech Guru astromech's Avatar
    Join Date
    Jun 2009
    Location
    West Yorkshire
    Posts
    1,674

    Default

    No worries.
    A&H Xone:62 | 2 x NI Kontrol X1 MK2 | 2 x 1210s | TSP2 | Audio 10 | Apple Macbook Pro 13 inch | Sennheiser HD7 DJ | Ableton Push
    read: http://djworx.com/author/dan-morse
    talk: http://facebook.com/bleeptechno
    listen: http://mixcloud.com/bleephudds

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •