Midi device not detected, hercules mk2 --> traktor
Results 1 to 2 of 2
  1. #1
    Tech Convert
    Join Date
    Jan 2010

    Default Midi device not detected, hercules mk2 --> traktor

    It started with that i was trying to connect a xbox controller (hid device) to my computer and then translate it to midi so that i could use it with traktor. read more about the principle here: http://www.djtechtools.com/2009/05/2...itars-rejoice/

    I tried to make this work in several different ways on my powerbook g4. First i tried to connect my xbox360 controller to midi, then i tried a normal gamepad and different drivers/apps that makes it possible to connect this to your mac. just for fun i configured the joystick on my hercules mk2 to control the mouse, which worked. but i didnt find a good way to convert the hid to midi, except for junxion, but that is kind of expensive, so i gave up.

    I connected the hercules mk2 to my traktor 3 again, but it didn`t recognize it at all, well, it did recognize the audio interface part, which i could use, but there was no connection at all to the midi part.

    I think this has something to do with all the other drivers i installed. So i uninstalled all the apps and things that were added in the system preferences pane with a uninstaller called amnesia. although i can be completely wrong about this theory, could be anything.

    reinstalled the latest drivers for hercules mk2, but now i have no connection at all to the mididevice. not even in the standard midi software that is in the system utilities in mac osx.

    i searched the web for a couple of days now, but i cant find anything about this. ive tried the NI forums, and the hercules tech support, but no luck.

    So this what we could call my last resort, does anyone have any idea what is wrong? are there some drivers that are interfering with my mk2 even though i uninstalled the apps?

    Is there some special folder for drivers on mac that i can get to and manually delete something?

    Yesterday i installed a korg nanoPAD and that works excellent, so whatever is blocking (if that even is the problem) the mk2 doesnt seem to affect the nanopad. might be because the korg has the korg nanoeditor, i dont know.

    Is there any way to just reset the drivers?

    please help me out on this one, im out of ideas. if anyone has a knows of a better place to turn to, just tell me and i`ll be gone.

    thanks in advance

    ps, if you need any more info considering my setup, just ask and i'll be happy to tell you.

  2. #2
    Tech Guru sj03w4t's Avatar
    Join Date
    Sep 2009


    In windows there is something called device manager in which you can see all installed devices and you can remove them. Maybe there a mac equivalent so you can look for devices which you might have forgotten to remove..

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts