paid for firmware 1.3 upgrade through Vestax, but didn't get it
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    Default paid for firmware 1.3 upgrade through Vestax, but didn't get it

    ...As the title says, I paid for the firmware 1.3 upgrade through Vestax, but didn't get it.

    I had to take it back to my local shop to get the left jog wheel sensitivity dial on the back replaced after falling off. They had to send it to Vestax Canada to be fixed, so I thought this would be a good time to get the firmware 1.3 upgrade.

    When I got it back, I noticed that DJ Techtools .TSI file didn't work properly, so I ran the test (hold both vinyl button) as listed on this forum, and not surprisingly, I realized I still had firmware 1.2...But I paid $80 for it, even though it already had firmware 1.2

    Is there any other way for me to prove to my local shop that I had to pay for something I didn't get? The reason I say this is because they don't really have a lot of experience with controllers, so me having to prove my point would probably involve having to use their computer to connect my VCI-100, and show them this site to show them the firmware test.

    I've had a history of buying defective equipment from these guys, so I would prefer to have a more definitive way of proving that I just paid for something I didn't get.

  2. #2
    Tech Guru sarasin's Avatar
    Join Date
    Jun 2009
    Location
    Cape Town
    Posts
    5,082

    Default

    Hiya.

    AFAIK, the 1.3 firmware is not supported by Vestax. It is only available on DJTT.

    I stand to be corrected tho....
    APC80:STR8-100's+Ortofon Concorde Scratch\Electro:ButterRugz:TSP2-NI Audio4DJ:Xone22+Innofader:MacBook Pro 15"
    www.soundcloud.com/djsarasin
    www.youtube.com/adriansarasin

  3. #3
    Dr. Bento BentoSan's Avatar
    Join Date
    Mar 2008
    Location
    Perth, Australia
    Posts
    6,383

    Default

    with the 1.3 firmware the jog wheels will still turn off if you press both vinyl mode buttons.

    I personally test by holding the top little black button closest to the on/off switch when i turn on the unit on - if the LED lights up next to the button as the unit boot then you know that you have the 1.3 firmware.

    Holding the button down as you power the unit on boots into 1.2 mode, if you want to get back to 1.3 mode just turn your unit off, then back on again without holding anything.

  4. #4

    Default

    Quote Originally Posted by BentoSan View Post
    with the 1.3 firmware the jog wheels will still turn off if you press both vinyl mode buttons.

    I personally test by holding the top little black button closest to the on/off switch when i turn on the unit on - if the LED lights up next to the button as the unit boot then you know that you have the 1.3 firmware.

    Holding the button down as you power the unit on boots into 1.2 mode, if you want to get back to 1.3 mode just turn your unit off, then back on again without holding anything.
    Do you hold the button down before you turn it on?

    If so, I did that, and yeah the red light next to it lights up.

    The weird thing is that tried loading the custom SE mapping from the mapping section, and it didn't work properly...But the second I loaded a member's mapping that was made for firmware 1.2, it work properly?

    I was under the impression that mappings for 1.2 didn't work properly if you had 1.3?

  5. #5
    Dr. Bento BentoSan's Avatar
    Join Date
    Mar 2008
    Location
    Perth, Australia
    Posts
    6,383

    Default

    Yes you hold down the button when you turn it on.

    The DJTT mapping works somewhat with the 1.2 version of the firmware but not fully - the main thing that has issues are the 4th effects buttons being the same as the 2 buttons in between the eq's

  6. #6

    Default

    Quote Originally Posted by BentoSan View Post
    Yes you hold down the button when you turn it on.

    The DJTT mapping works somewhat with the 1.2 version of the firmware but not fully - the main thing that has issues are the 4th effects buttons being the same as the 2 buttons in between the eq's
    Seeing as how I'm fairly certain I have firmware 1.3...What do you think the issue is with the DJTT mapping?

    The one key thing I noticed is that a lot of the faders turn clockwise when I'm actually turning it counterclockwise?

  7. #7
    Tech Wizard
    Join Date
    Jun 2009
    Location
    Copenhagen, Denmark
    Posts
    39

    Default

    It seems like you have to fight for getting your money back. I would say you have to take your VCI to the shop and show them how things work
    But you they gotta pay you back because vestax does not support 1.3 firmware so you might say they have promised you something they cant do :/

    EDIT: i noticed on the firmware 1.2 that the crossfaders does not work in fader fx mode.

  8. #8
    Tech Guru
    Join Date
    Feb 2009
    Location
    Zurich
    Posts
    855

    Default

    you are aware of the fact that firmware 1.3 supports falling back to 1.2?
    you can switch back and forth.

    by turning off the unit and pressing and holding the top left upper black button (those tiny buttons) you switch to 1.2

    by turning off the unit and pressing and holding the second to the top left upper black button (those tiny buttons) you switch to 1.3
    Traktor Pro 2.5.0, Mixxx 1.9.1, Massive, Ableton Live 8
    MBP 15" 8GB RAM OS 10.7.4, Audio Kontrol 1, Audio 2 DJ, Sennheiser HD-25 II
    DJTT VCI-100SE Arcade, Akai LDP8, M-Audio Pro Keystation 88, Novation Launchpad, iTM DJ
    ifnotwhynot.me | soundcloud.com | fairtilizer.com | digitaldj planet | digitaldj music

  9. #9

    Default

    Quote Originally Posted by Djaevi View Post
    It seems like you have to fight for getting your money back. I would say you have to take your VCI to the shop and show them how things work
    But you they gotta pay you back because vestax does not support 1.3 firmware so you might say they have promised you something they cant do :/

    EDIT: i noticed on the firmware 1.2 that the crossfaders does not work in fader fx mode.
    ...But I don't understand...I just did the test that BentoSan suggested, and It proved that I have firmware 1.3?

  10. #10

    Default

    Quote Originally Posted by lsmith View Post
    you are aware of the fact that firmware 1.3 supports falling back to 1.2?
    you can switch back and forth.

    by turning off the unit and pressing and holding the top left upper black button (those tiny buttons) you switch to 1.2

    by turning off the unit and pressing and holding the second to the top left upper black button (those tiny buttons) you switch to 1.3
    This test is different from the one that BentoSan posted...But also, this test doesn't give me a clear indication of lights turning on or off, to indicate whether I actually do have firmware 1.3 or not.

    Can someone give me a concrete answer so that I can know whether I should call my local shop or not?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •