iTunes Tracks "lost" in Traktor Pro
Results 1 to 6 of 6
  1. #1

    Default iTunes Tracks "lost" in Traktor Pro

    Hello all,

    I am not sure whether this issue came up before, at least I couldnīt find anything about this exact problem..

    The basics:
    Max OS X 10.5.8
    Traktor Pro 1.2.3
    iTunes 9.0.3 (15)

    Maybe someone can help: about half of my tracks in the iTunes library can be found, but not loaded in Traktor. Dragging the tracks to the decks just doesnīt work. In iTunes, everything works as usual - tracks are listed and can be played.
    And: ALL of my tracks in the Traktor playlists do not work any more - dragging them to the decks has no effect.

    I have not changed or moved the iTunes library, I just update iTunes to the newest version from time to time, but that shouldnīt be the reason I guess.


    Thank you,

  2. #2
    Tech Guru
    Join Date
    Nov 2009


    Have you attempted to manually navigate to the directory and select an mp3 track?. It could potentially be that your library was created on an previous version of iTunes, and when updated, it somehow "displaced" it within the program itself. Have you tried consolidating the collection within iTunes?

  3. #3


    Thank you!

    I guess weīre moving in the right direction: I just tried to manually search for tracks in the iTunes Music Folder (Traktor Explorer/ Macintosh HD/..) and found out, that there are many folders missing! I can see the complete folder list in the finder, but not in Traktorīs explorer. But - the tracks are shown in the iTunes playlist. Itīs not only the recently added stuff, but also some old tracks. How could that happen? What can I do?

  4. #4
    Tech Guru keeb's Avatar
    Join Date
    Oct 2009


    Sounds like a DRM issue. If those are files you've downloaded with iTunes, check if they're .m4p files. This doesn't sound like the answer to the whole issue, but may be part of the problem. When you try to load a track, do you see any messages in the bar underneath the file browser?

    EDIT: Just saw your new post. When you move a music file after it's already been added to the itunes library, that creates the problem where itunes can't find the file. You'll see an ! next to the track in itunes after you try to play it if itunes can't find the file. Sadly to fix this you need to manually fix the file locations, or re-add all of the music that's not working. Consolidating the library via itunes can work, but it can also create horrendous amounts of duplicate files. Be careful with it.
    Last edited by keeb; 02-16-2010 at 02:53 PM. Reason: New post by OP

  5. #5


    @keeb: thank you! But - the problem is not with iTunes (in iTunes, all tracks work fine) but with Traktor. Further: I have never touched the iTunes Music Folders..

    when trying to drop a track from the traktor playlist to a deck, I see a yellow "!" in the track browser. when trying to open a track from the iTunes playlists, it just doesnīt load, but no "!" or something is shown.
    Last edited by maxi.million; 02-16-2010 at 03:07 PM.

  6. #6


    seems like this thread is about to die early.. maybe someone still has an idea? I have no clue what to do.. thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts